11

I use Ubuntu 18.04 and Lenovo Ideapad 320. There is a problem with microphone. In Google Meet, the built-in microphone doesn't work.

However, on the settings page(of Google meet) built-in microphone is selected as source input. The microphone indicator shows that I produce the voice however my interlocutors do not hear me.

I also tried to use the USB headset - the same result(of course I previously selected the headset as source on Ubuntu settings and in google meet's settings). Interestingly that for example in slack everything works fine(external USB headset also works, but it requires re-login to the Ubuntu session).

In all situations, I can hear my interlocutors. Thanks in advance! I've already checked similar questions related to hangouts on askubuntu.com, nothing helped.

2 Answers 2

11

I had this problem, with this laptop and Ubuntu 18.04. These steps work for me. They also work for me on Ubuntu 20.04.

Start up PulseAudio Volume control (pavucontrol). In the "Recording" tab, set "Show:" to "All Streams". In the "Input Devices" tab, set "Show:" to "All Input Devices". Change "Built-in Audio Analogue Stereo" to "Port: Internal Microphone", and click the lock icon so that "Front Left" and "Front Right" sliders appear. Move the "Front Left" slider for "Internal Microphone" so it lines up with "Base", and move the "Front Right" slider so it lines up with "Silence".

Follow the link to the Google Meet event. If prompted, allow Google Meet to access the microphone (called something like "Monitor of built-in audio analogue stereo"), and the camera.

Back in pavucontrol, go to the "Recording" tab. Change "Firefox: AudioCallBackDriver from" to "Built-in Audio Analogue Stereo". Move the slider so it lines up with "100%".

Join your meeting.

8
  • Huge thanks for the tip. It actually worked! I've been having this issue using Ubuntu, Linux Mint and even Arch Linux or Manjaro. For some reason, the default combined input volume is messed up. Disabling the padlock "Lock channels together" and tweaking each volume slider independently solves the issue. Either left or right input is messed up. Sliding one of them down to base level fixed the issue for me. Best regards!
    – JulioHM
    Jun 13, 2020 at 17:07
  • 3
    @Gareth Walker it worked! But now, this s* ubuntu keep reseting all the sliders. Jul 8, 2020 at 12:18
  • good solution for 20.04. Nov 9, 2020 at 23:39
  • @PlayHardGoPro Did you figure out how to save the settings? Nov 23, 2020 at 11:08
  • 1
    @AnshumanKuma Yes and No. PulseAudio did solve my problem. But everyday I need to change the sliders again and sometimes it changes by itself and I need to configure while talking hahah. Ubuntu, man... Nov 23, 2020 at 14:57
0

I had a similar problem on Ubuntu 20.04. I solved it by going to "Settings > Sound" and checking every device until I found one that worked. I choose one by one from the "Input device" checkbox until I could see the bar below flickering when I made sounds: An animated GIF where the GNOME's "Sound" settings show a chosen microphone not working. Then I change it to another input device, and a bar below it starts flickering in red following sounds I make close to the microphone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.