1
  • Ubuntu 18.04 64bit
  • libreboot
  • flashrom 0.99

The matter is beyond my skills.

I want to flash libreboot on a gigabyte mainboard.

I got the ROM file, renamed it to libreboot.rom and tnstalled flashrom.
Then I ran the command

flashrom -p internal:dualbiosindex=0 -w libreboot.rom

But it did not work.

I was told to edit grub to add iomem=relaxed.

At the Ubuntu location Computer > etc > default > grub, the grub file has:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Shall I edit

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

into

GRUB_CMDLINE_LINUX_DEFAULT="iomem=relaxed quiet splash"

with nano?

1
0

You can use nano but personally I do everything with gedit both in my regular user account and with sudo. In this case sudo is needed so it would be:

sudo -H gedit /etc/default/grub

Then change:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to:

GRUB_CMDLINE_LINUX_DEFAULT="iomem=relaxed quiet splash"
  • Save the file
  • Exit gedit
  • Run sudo update-grub
  • Type reboot

After rebooting type:

cat /proc/cmdline

You will see your changes in effect. Whether everything works or not is a different story :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.