I hope you can help me figure out how to set the brightness at my netbook. Following problem appears since I installed ubuntu 11.10 on my acer: I am not able to adjust the brightness by FN Keys nor manually at "systemsettings-display". After searching with google for a while, I found a way via the terminal to adjust it with the folloqing command: "sudo setpci -s 00:02.0 f4.b=7f" ( from 00-9f). That was a major breakthrough for me as I am still new to Linux OS. But still seeking a way to get the FN keys for brightness to work, I kept searching until I found "askubuntu.com". I read through various Questions by other acer users and tried there solutions, but unfortunately none worked out for me. From this thread: fn + arrow keys don't adjust actual brightness on an Acer Aspire 5740 "sudo gedit /etc/X11/xorg.conf". This command did not work because the file was not found. I also used nano instead of gedit, but the file was empty( I think it just created the file since it did not exist).

These commands which i found gave me a boot loop and I had to repair ubuntu: sudo gedit /etc/default/grub

Change the line GRUB_CMDLINE_LINUX="" into GRUB_CMDLINE_LINUX="acpi_osi=Linux"

sudo update-grub

From this post Screen Brightness not adjustable for Acer Aspire S3:

I tried the solution from the last post, but it did not work either.

Does anyone know what I could try? I would appreciate it, if someone could help me out with this.

Thanks in advance

Netbook specs:

CPU: Intel Atom N2600 Memory: 2gb DDR3 Storage: 320 GB HD GPU: Intel GMA 3600

  • Intel GMA 3600 is not supported at ubuntu - sorry :) I've got the same problem...
    – user51605
    Mar 22, 2012 at 9:19
  • +1 for figuring out the terminal command for adjusting brightness
    – Cerin
    May 2, 2012 at 1:00
  • I know that this is a old post, but for the people searching for their Acer D270. The keys are okay in Ubuntu 12.04
    – robertnl
    Sep 25, 2012 at 20:34

2 Answers 2


Try to configure directly.

sudo setpci -s "00:02.0" F4.B=FF

Where F4.B=FF <-- This FF is rhe intensity of bright in hexa values.

I use:

sudo setpci -s "00:02.0" F4.B=11

For example.

If you wanna more information, try to read this page. But, the original is in portuguese:


Have a nice day!

  • It would be nice if there was some way to bind this action to a brightness key.
    – Cerin
    May 2, 2012 at 1:02

Currently Ubuntu doesn't support it - the bug is "triaged" - mothballed indefinitely.

You can get it going if you're willing to roll your own kernel, but my general advice is against it - the new kernel broke so many things (e.g. networking) that backlight control was simply not worth it.

Anyway, if you want to get it going for whatever reason, e.g. hope you can get the rest of the missing hardware running, get a kernel version at least 3.5.X from kernel.org, make sure CONFIG_DRM_GMA3600 is switched on, and use backlight=vendor on the kernel command line (in GRUB).

  • I'm not sure what you mean by "mothballed", but "triaged" means a developer or an approved bug triager has recognised this as a valid bug that needs to be worked on, so it's actually a good sign.
    – Flimm
    Mar 14, 2013 at 21:31
  • @Flimm: It's been triaged nearly a year ago "because it needed upstream fix". Not quite true because at that time kernel 3.5, with a working fix, was available already, but that was discovered only 4 months later. Still, acknowledging that the bug needs to be fixed is a far cry of doing anything about having it fixed.
    – SF.
    Mar 15, 2013 at 9:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .