I've already had this problem before but I don't know how I solved it.

Ubuntu becomes very slow (mouse jumps from point to point) when I connect to power. The problem was related to a CPU feature that was activated when power was connected. I don't remember which feature it was. Can someone remember it?

When the system initiates, it takes some seconds for the computer to freeze, like it was the start of some process that made the slowness start

2 Answers 2


Could have something to do with C-States or P-states which refer to power modes that a CPU can use in order to efficiently use power/frequency without loosing performance. Here’s a post that explains the details.

I had a laptop that used to freeze because of a non-supported c-state and had to set intel_idle.max_cstate=1 to my GRUB configuration as a boot parameter GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub

A useful place to know more about your cpu frequency managment is:

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver

mine is: acpi-cpufreq

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors

mine are: conservative ondemand userspace powersave performance

Would be curious to know how it goes

  • this problem hasn't happened for years but it just happened now for no reason. cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors gives me performance powersave both on AC and without AC connection Feb 22, 2019 at 20:57
  • and my scaling driver is intel_pstate Feb 22, 2019 at 20:58
  • the boot parameter didn't work. Something important: the slowness starts after some time after the system intiates, like it was something starting up in the system Feb 22, 2019 at 21:00
  • I've found the solution, but thank you! Feb 22, 2019 at 21:34

The solution was that I was using a faulty power extender. The ubuntu wouldn't show it was charging but the connection kinda worked and I think the CPU was making up for the slow energy it was receiving. I simply connected the charger directly to the AC and it worked and showed it was charging

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.