6

I'm running Ubuntu 18.04LTS. I have an HP Photosmart C7280 color printer. The printer is attached over the local network. This has worked nicely for me for a long time.

But today, suddenly, everything I print gets a solid blue background. I can still read the text, but the entire page background is blue. Other computers can print to the same printer without problems; the blue background is only added on one computer.

I've tried restarting both the computer and the printer. I've removed the printer from my Linux configuration and added it again. The result is always the same. Even the print test page feature of the printer installation program adds a blue background.

What can I do?

EDIT

The problem seems to be caused by an update to ghostscript. My ghostscript 9.26 was updated today. I tried another Linux system with an older version of ghostscript 9.26, and it worked nicely. I then updated ghostscript on that system, and then I got a blue background.

How do I force the system back to the older (working) version of ghostscript?

EDIT2

This is definitely a bug. It has been reported by others in the Ubuntu bug tracker: https://bugs.launchpad.net/ubuntu/+source/ghostscript/+bug/1817308

closed as off-topic by user68186, karel, Eric Carvalho, Charles Green, DK Bose Feb 23 at 13:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – user68186, karel, Eric Carvalho, Charles Green, DK Bose
If this question can be reworded to fit the rules in the help center, please edit the question.

2

Installing an older version of ghostscript restores the ability to print properly.

I run this command:

sudo apt install ghostscript=9.18~dfsg~0-0ubuntu2 \
libgs9=9.18~dfsg~0-0ubuntu2 \
libgs9-common=9.18~dfsg~0-0ubuntu2

and now my Ubuntu 16.04 prints properly.

In order to stop the update happening again, I run this command:

sudo apt-mark hold ghostscript=9.18~dfsg-0-0ubuntu2

Reference: Bug #1817308 “GhostScript Update causes Blue Background”

  • I don't know how but ghostscript updated itself again to 9.26 and still does not work, this time giving an error message: "filter failed". So I went back to 9.18 and it works again. – bullfrog55 Feb 26 at 1:59
  • where do I do that? – bullfrog55 Feb 26 at 4:23
  • ok, so now I'll go to Launch pad and try to report a bug there. Though I can't see why this is not an appropriate forum - 16.04 LTS would not seem to be a development version, but then I'm rather new to this and am only trying to help other people who may also be banging their head against a brick wall trying to get their printer to do a simple print. – bullfrog55 Feb 28 at 2:45
  • Just updated and the problem persists: "filter failed" – bullfrog55 Feb 28 at 4:08
  • As of 6/3/19 the update finally works. – bullfrog55 Mar 6 at 6:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.