1

My Synaptic Touchpad stopped working in the past few weeks.

The touchscreen and external mouse still work so I've been using them to work around it.

The symptoms are:

  • Touchpad works on login screen
  • Touchpad stops working after login screen
  • All other inputs work, including keyboard, touchscreen, external mouse, docking station, etc.
  • Doesn't work on Wayland, either.
  • F7 key comes up with a square with an X in the bottom-right corner, but the X won't go away no matter how many times I press it.
  • sudo rmmod usbhid; sudo modprobe usbhid enables the touchpad for a split second.

For the previous few weeks, I've been able to resurrect the touchpad with sudo rmmod usbhid; sudo modprobe usbhid so I suspect that this issue is in two parts.

xinput list shows:

 Virtual core pointer                       id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SYNA7500:00 06CB:780B                     id=16   [slave  pointer  (2)]
⎜   ↳ Synaptics T Pad V 01.31 Touchpad          id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Integrated_Webcam_FHD: Integrat           id=12   [slave  keyboard (3)]
    ↳ Integrated_Webcam_8M: Rear Inte           id=13   [slave  keyboard (3)]
    ↳ Intel Virtual Button driver               id=14   [slave  keyboard (3)]
    ↳ SYNA7500:00 06CB:780B Pen                 id=15   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=17   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=18   [slave  keyboard (3)]
    ↳ Synaptics T Pad V 01.31 Consumer Control  id=8    [slave  keyboard (3)]
    ↳ Synaptics T Pad V 01.31                   id=9    [slave  keyboard (3)]
    ↳ Synaptics T Pad V 01.31 Wireless Radio Control    id=10   [slave  keyboard (3)]

I have tried:

  1. Installing the synaptics driver
  2. Adding in a libinput filter (which made the Synaptics T Pad V 01.31 Touchpad above disappear, but actually made it worse)
  3. `xinput set-prop 11 "Device Enabled" 1 (0 followed by 1 as well)
  4. `xinput set-prop 16 "Device Enabled" 1 (0 followed by 1 as well)

This is on kernel 4.18.0-15-generic, but I have also tried going back to 4.17 and it doesn't work, either. I can't roll back to any earlier versions of xserver-xorg-input-* because they don't appear to be available.

I suspect that the touchpad may be programattically disabled (which would explain the X in the F7 status) but I don't know how to programatically re-enable it.

How do I get my touchpad back?

  • See this answer here: askubuntu.com/a/624929/167115 – mchid Feb 22 at 1:07
  • As a user mentions, you may have to toggle the setting by setting "enabled" to 0 and then by setting "enabled" to 1 but hopefully setting it to 1 the first time will work. If not, please let me know because there may be a different solution. – mchid Feb 22 at 1:08
  • Also, does the cursor appear on the screen? Sometimes the cursor disappears and so it seems like the touchpad is not working but, in fact, the touchpad is working fine but the cursor is invisible. – mchid Feb 22 at 1:11
  • 1
    No, there is no activity from the touchpad. I've seen that before. – tu-Reinstate Monica-dor duh Feb 22 at 1:21
  • Plus, this also happened to my boss with the same machine just days apart. – tu-Reinstate Monica-dor duh Feb 22 at 1:21
0

According to the Ubuntu help docs, this problem is often solved using the following command:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

You can also enable or toggle the touchpad using synclient instead of xinput.

To enable:

synclient touchpadoff=0

To toggle:

synclient touchpadoff=1
synclient touchpadoff=0

Additionally, you could try using a different device listed like device 16 instead of 11:

xinput set-prop 16 "Device Enabled" 1

click here for additional information

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.