1

It's been addressed here GDM3 does not start in Ubuntu 18.04 but none of the solutions proposed worked for me (and the topic is about 18.04).

I have disabled wayland as proposed, but did not solve the problem.

If i connect thru SSH and sudo systemctl start gdm it will work and start gdm. But if i boot the system, it just gives a blank (black) screen.

sudo systemctl enable gdm does not work. It gives a comprehensive message that it's not the correct way to enable this service.

How can I re-enable gdm?

Have also tried to uninstall and then install it again (the gdm package) - did not work.

1

Try this command to choose a login manager:

sudo dpkg-reconfigure gdm3

You should be able to select gdm3.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.