1

I have been using Ubuntu for quite sometime now. I have a dual boot system with Windows 10 and Ubuntu 18.04. I have used this combo ever since Ubuntu 18.04 came out. Earlier, grub would always show and accept 1920x1080 as its display resolution. I have had various system crashes along the way due to which I have had to install Windows and Ubuntu thrice. Recently, I have noticed a peculiar thing. My grub doesn't show 1920x1080 resolution when I use videoinfo command at grub terminal. The highest that it goes is 1280x720. I have tried to fix it by manually making an entry in the grub file but it was of no help.

My grub file config is as follows:

Can anyone please suggest me a possible fix for it? Is there something wrong with the OS? Is there something wrong with the BIOS (MSI Motherboard)? Is there something wrong with the drivers?

Note: I am running in UEFI mode.

  • Use locate vudeoindo and then ll followed by one space and copy and pasted result from the locate command. What is the date and time for the module? Mine is January 2019 and 1929x1080 still works fine. – WinEunuuchs2Unix Feb 21 '19 at 23:07
  • When you are in grub, press c, and at command prompt grub> type videoinfo. What is grub's output? Do you get something similar to what I had described in section "Update 1" of my question? – Sun Bear Apr 26 '19 at 16:19
1

Edit the file /etc/default/grub and find the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Then change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=hyperv_fb:1920x1080"

See that this will sort out your problem. Also note the advice at the beginning of the file:

If you change this file, run 'update-grub' afterwards to update /boot/grub/grub.cfg.

| improve this answer | |
0

There's very little video control at the GRUB screen level. It's best to leave /etc/default/grub at...

GRUB_GFXMODE=640x480

This parameter only effects the GRUB screen, and this setting will display large enough font characters for easy viewing.

Followed by...

sudo update-grub

Also see...

How to fix plymouth (splash screen) in all Ubuntu releases!

Nvidia Grub max boot resolution 1280x1024 (15.10)

Grub-Efi wrong resolution

| improve this answer | |
  • I used to do it that way too but you can really do a lot with grub video. I'll try to post something later. – WinEunuuchs2Unix Feb 20 '19 at 23:02
  • No, I want to know why am I unable to set my grub resolution beyond 720p now when earlier I could do it with a breeze. What could be the solution to the problem? The main thing is that I am trying to fix my slpash screen after my nvidia driver installation but it is quite low res. And I pretty sure that as various solutions have stated, if I can change the resolution of the grub, the resolution of the splash screen would too. – c2yCharlie Feb 21 '19 at 2:32
  • @c2yCharlie I don't know if display managers even come into play this early, but could it be the difference between lightdm and gdm3? Maybe even the nvidia drivers? – heynnema Feb 21 '19 at 4:03
  • @c2yCharlie I'd worry more about "I have had various system crashes along the way due to which I have had to install Windows and Ubuntu thrice". Do you know why this occurred? – heynnema Feb 21 '19 at 14:49
  • Yes, I know. Most of them were due to my foolishness. Nothing that happened all by itself or due to some system fault. However, I cannot think of a single reason why grub would stop displaying 1920x1080 in videoinfo as it used to previously. No matter how many grub changes I make, it just doesn't accept this resolution and always reverts back to 1280x720. I had installed proprietary drivers for Nvidia which caused my splash (plymouth) to revert to a low resolution. Prior to the driver installation, the splash screen was running on my native resolution. The whole matter is pretty strange. – c2yCharlie Feb 21 '19 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.