1

I have a wireless Logitech keyboard and mouse connected to my Dell laptop. After it suspends, I can't wake it with the mouse or keyboard without opening the laptop lid (I normally work with it closed and use an external monitor). If I open the lid a crack, mouse movement wakes it. In the system BIOS I have set the Power Management -> USB Wake Support switch to Enabled. The suggestions in the responses to question 848698 don't seem to apply because the referenced wakeup file is already set to enabled. That is on my system:

grep . /sys/bus/usb/devices/*/product

yields

/sys/bus/usb/devices/1-11/product:Integrated_Webcam_HD
/sys/bus/usb/devices/1-3/product:USB Receiver
/sys/bus/usb/devices/usb1/product:xHCI Host Controller
/sys/bus/usb/devices/usb2/product:xHCI Host Controller

and

grep . /sys/bus/usb/devices/*/power/wakeup

yields

/sys/bus/usb/devices/1-14/power/wakeup:enabled
/sys/bus/usb/devices/1-3/power/wakeup:enabled
/sys/bus/usb/devices/usb1/power/wakeup:disabled
/sys/bus/usb/devices/usb2/power/wakeup:disabled

I'm not sure what else to try.

0

Was able to solve this issue by adding the following line to the root crontab file:

sleep 30 && echo XHC > /proc/acpi/wakeup

Without the delay, this didn't work because the wakeup settings were modified after the crontab commands were executed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.