2

Installing emacs under 18.10 (Cosmic Cuttlefish) fails

When I search for libotf, it is there:

locate libotf.so
/usr/lib/x86_64-linux-gnu/libotf.so

So why does fixing the install fail?

sudo apt install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up emacs-gtk (1:25.2+1-11) ...
Install emacsen-common for emacs
emacsen-common: Handling install of emacsen flavor emacs
emacs: error while loading shared libraries: libotf.so.0: cannot open shared object file: No such file or directory
ERROR: install script from emacsen-common package failed
dpkg: error processing package emacs-gtk (--configure):
 installed emacs-gtk package post-installation script subprocess returned error exit status 1
No apport report written because the error message indicates its a followup error from a previous failure.
                          dpkg: dependency problems prevent configuration of emacs25:
 emacs25 depends on emacs-gtk (>= 1:25); however:
  Package emacs-gtk is not configured yet.

dpkg: error processing package emacs25 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 emacs-gtk
 emacs25
E: Sub-process /usr/bin/dpkg returned an error code (1)
2
  • 1
    Try this: sudo ln -s /usr/lib/x86_64-linux-gnu/libotf.so /usr/lib/x86_64-linux-gnu/libotf.so.0 and try again. – Jos Feb 20 '19 at 12:59
  • added your symbolic link, sudo apt remove emacs-gtk, then sudo apt install emacs-gtk. Same problem – Dov Feb 20 '19 at 13:10
1
sudo apt install libotf0

worked for me. You might also need to install libm17n-0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.