-1

I successfully mounted a Windows share folder by editing /etc/fstab. Now I'm trying to rsync Ubuntu folders to the mounted Windows share folder in Ubuntu system.

I'm using the command rsync -av --delete /sourceFolder/ /Mounted cifs format windows share folder/. Everything works fine without the option for the permissions.

The copied file permissions follow the uid, gid, dir_mode options in /etc/fstab file, not the rsync -a option.

Is there a workaround to preserve the file permissions when backing up? Or is my approach wrong fundamentally?

1
  • This is an important issue for me. Otherwise I have to spend a lot of money. Would anyone please give me a solution? – Smile Feb 20 '19 at 7:40
-1

You can use the flag -p to preserve permissions.

1
  • 2
    While this answer may point to the correct usage, the lack of explanation and no useful detail makes this answer almost useless. – user37165 Feb 21 '19 at 9:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.