0

I have Nvidia graphics card installed and the Ubuntu used to work without any issue till yesterday. Unfortunately, it is now stuck at the login screen. I switched to terminal mode (Ctrl+Alt+F1) and removed Nvidia drivers using the following command:

sudo apt-get purge nvidia-*

It works! However, I want to use Nvidia drivers so after logging in successfully, I installed Nvidia drives from "additional drivers" under "software and updates" in Ubuntu. After rebooting, it again stuck at login screen.

Below is the permission info. for .Xauthority file:

ravi@lab:~$ ls -la .X*
-rw------- 1 ravi ravi 48 Feb 20 11:43 .Xauthority
-rw------- 1 ravi ravi 48 Feb 20 11:27 .Xauthority.bak

I am not able to figure out the cause of the problem. Below is the content of dmesg:

[    1.342426] init: plymouth-upstart-bridge main process ended, respawning
[    1.544607] Adding 16734204k swap on /dev/sda3.  Priority:-1 extents:1 across:16734204k SSFS
[    1.594473] systemd-udevd[359]: starting version 204
[    1.596107] tsc: Refined TSC clocksource calibration: 3600.032 MHz
[    1.620273] lp: driver loaded but no devices found
[    1.631667] ppdev: user-space parallel port driver
[    1.649728] wmi: Mapper loaded
[    1.651556] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[    1.681165] [drm] Initialized drm 1.1.0 20060810
[    1.690956] type=1400 audit(1550630628.420:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=487 comm="apparmor_parser"
[    1.690962] type=1400 audit(1550630628.420:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=487 comm="apparmor_parser"
[    1.690965] type=1400 audit(1550630628.420:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=487 comm="apparmor_parser"
[    1.691995] type=1400 audit(1550630628.420:5): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/sbin/dhclient" pid=493 comm="apparmor_parser"
[    1.691999] type=1400 audit(1550630628.420:6): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=493 comm="apparmor_parser"
[    1.692002] type=1400 audit(1550630628.420:7): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=493 comm="apparmor_parser"
[    1.693989] snd_hda_intel 0000:00:1f.3: irq 182 for MSI/MSI-X
[    1.768260] checking generic (d1000000 7f0000) vs hw (c0000000 10000000)
[    1.768261] checking generic (d1000000 7f0000) vs hw (d0000000 2000000)
[    1.768262] fb: conflicting fb hw usage nouveaufb vs EFI VGA - removing generic driver
[    1.768280] Console: switching to colour dummy device 80x25
[    1.768906] nouveau E[  DEVICE][0000:01:00.0] unknown chipset, 0x134000a1
[    1.768910] nouveau E[     DRM] failed to create 0x80000080, -22
[    1.769175] nouveau: probe of 0000:01:00.0 failed with error -22
[    2.019597] EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro
[    2.229627] init: failsafe main process (750) killed by TERM signal
[    2.415213] Bluetooth: Core ver 2.17
[    2.415250] NET: Registered protocol family 31
[    2.415251] Bluetooth: HCI device and connection manager initialized
[    2.415255] Bluetooth: HCI socket layer initialized
[    2.415257] Bluetooth: L2CAP socket layer initialized
[    2.415259] Bluetooth: SCO socket layer initialized
[    2.418438] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    2.418447] Bluetooth: BNEP filters: protocol multicast
[    2.418451] Bluetooth: BNEP socket layer initialized
[    2.425587] Bluetooth: RFCOMM TTY layer initialized
[    2.425608] Bluetooth: RFCOMM socket layer initialized
[    2.425634] Bluetooth: RFCOMM ver 1.11
[    2.446701] type=1400 audit(1550630629.176:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=837 comm="apparmor_parser"
[    2.446704] type=1400 audit(1550630629.176:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd" pid=837 comm="apparmor_parser"
[    2.465787] init: cups main process (842) killed by HUP signal
[    2.465817] init: cups main process ended, respawning
[    2.497078] type=1400 audit(1550630629.224:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cups-browsed" pid=916 comm="apparmor_parser"
[    2.558491] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    2.588489] init: alsa-restore main process (1031) terminated with status 19
[    2.598291] Switched to clocksource tsc

Below is the content of sudo lshw -c video

ravi@lab:~$ sudo lshw -c video
[sudo] password for ravi: 
  *-display UNCLAIMED     
       description: VGA compatible controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller cap_list
       configuration: latency=0
       resources: memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:df000000-df07ffff

PS: I know the similar type of questions is asked many times but I am not able to figure out the cause of this problem. I guess that some Nvidia configuration files need to be cleaned properly.

  • Looks like your drivers for nvidia are wrongly installed. Can you post the output of sudo lshw -c video? (Also, refer to this link for installing driver properly) – Sachit Shanbhag Feb 20 '19 at 5:12
  • Thank you very much. The output of sudo lshw -c video is added to the question. Nvidia driver was installed from "additional drivers" under "software and updates". Please let me know if you need more info. I am online! – Ravi Joshi Feb 20 '19 at 5:22
  • Please note that the output of sudo lshw -c video is taken after removing nvidia driver, because I cannot run sudo lshw -c video if the driver is installed, since the login stuck! – Ravi Joshi Feb 20 '19 at 5:32
  • I'm also using Ubuntu 14.04, and encountered the same problem, with the same "solution" (sudo apt-get purge nvidia-*). I've created a topic at: ubuntuforums.org/showthread.php?t=2413017. – user3409662 Feb 20 '19 at 9:13
  • @user3409662: yeah! I guess we both stuck at the same problem. Unfortunately, I am not able to identity the exact cause. Removing the Nvidia driver is not a permanent solution. – Ravi Joshi Feb 20 '19 at 9:45
2

I also was affected by this bug/effect. As workaround I also switched to the Nouveau driver first. As in the linked topic at ubuntuforums (from user3409662) was mentioned already, several packages have been updated last week, also shim-signed. Interestingly this package seems not to be necessary for me, because I disabled SecureBoot for my system (Ubuntu 14.04, Geforce GTX 750 Ti) by using mokutil some years ago (necessary to use VirtualBox again).

So I decided to uninstall shimsigned (used Synaptic for this), rebooted and saw no negative effects. In the terminal I installed my previously used Nvidia driver again: sudo apt-get install nvidia-410. No errors appeared and after rebooting the graphical login was working again, Nvidia driver loaded. Tested some games (native and Wine based ones) – everything worked.

  • Thanks, klicker for the suggestion. Before I proceed, let me confirm from you that you want me to remove shim-signed package but not shim? Also, you want me to disable the secure boot? I will apply your suggestions after your confirmation. Thanks again. – Ravi Joshi Feb 27 '19 at 5:21
  • @Ravi Joshi You are welcome. On my system shim and also systemd-shim are still installed. Probably not necessary anymore because I deactivated SecureBoot as mentioned above. But I didn't want to change to many packages at once and the effect appeared after shim-signed has been updated. – klicker Feb 27 '19 at 9:48
  • Thank you very much. I will remove shim-signed using synaptic and then will install NVIDIA using sudo apt-get install nvidia-410. Give me a few days as I am out of the city! – Ravi Joshi Feb 27 '19 at 13:35
  • 2
    It worked for me (sudo apt-get remove shim-signed, then sudo apt-get install nvidia-384, and then reboot). – user3409662 Feb 27 '19 at 16:33
  • klicker, you are God!!! Thank you so much for the suggestion. It worked well! Can you quickly describe, how did you find out the culprit? – Ravi Joshi Feb 28 '19 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.