0

I want to connect to my home wifi, which has a static IP configuration. I Have tried to set up the connection both using the GUI of network manager and by editing the network interface file, but in neither case I managed to connect to the internet.

The specifics of the configuration are:

  • IP address: 10.149.40.49
  • Netmask: 255.255.255.0
  • Gateway: 10.149.40.1
  • DNS: 10.149.32.2, 10.156.33.53

I know that this configuration works because I managed to connect to the internet using these parameters with both my phone and my other server running arch. But when I try to connect with my ubuntu server, I do successfully connect to the WiFi but i cannot resolve or ping any website. No problem arises when I try to connect to non-static networks. I am clueless on how to fix this, any help would be greatly appreciated.

$ ip route
  default via 10.149.32.2 dev wlp5s0  proto static  metric 600 
  10.149.32.2 dev wlp5s0  proto static  scope link  metric 600 
  10.149.40.0/24 dev wlp5s0  proto kernel  scope link  src 10.149.40.49 metric 600 
  169.254.0.0/16 dev wlp5s0  scope link  metric 1000 
  • Sorry, yes a typo the IP is 10.149.40.49. All the other parameters are correct though. These parameters were given to me, and they always worked so far, so I'm not sure if they are supposed to be different. – Elio Monaco Feb 19 at 23:58
  • The output of something like ip route might be helpful as well – steeldriver Feb 20 at 0:08
  • Yes, I also think that that's the issue, but I can't figure out why. I tried your suggestion, unfortunately it did not work. – Elio Monaco Feb 20 at 0:08
  • @ElioMonaco I didn't think it would, unless the gateway is also a DNS server. Edit your question and add what steeldriver above has asked. – Terrance Feb 20 at 0:09
  • @Terrance yes, sorry if it's getting confusion, I am nit used in using this forums. The ip route output was incorrect, since i forgot to disconnect the router i am now using to communicate. I added the actual output of the static router. I am using ubuntu 16.04 – Elio Monaco Feb 20 at 0:21
0

You can try the following (exchange wlp5s0 with your interface name):

Flush your configuration: sudo ip addr flush wlp5s0

Set your own configuration: sudo ip addr 10.149.40.49/24 broadcast 10.149.40.255 dev wlp5s0

Add a default route via your gateway: sudo ip route add default via 10.149.40.1

Add your dns-nameservers to resolv.conf: sudo nano /etc/resolv.conf

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1
nameserver 10.149.32.2
nameserver 10.156.33.53

All these settings will be lost after reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.