It seems that I have to deal with a classical grubrescue issue but despite many researches I can't fix it or find answers to some questions either.

What I did ?

I bought an Asus laptop 6 years ago with windows 7 pre-installed. I immediately installed Ubuntu and this dual boot configuration was working fine until I decided to restaure Windows with the recovery partition. I choosed to re installed in the entire hdd which was not the best idea.

Therefore, I get the famous grubrescue mode.

Error: no such partition.
grub rescue> ls
(hd0) (hd0,msdos3) (hd0,msdos2) (hd0,msdos1)
grub rescue> set

I understood the old Ubuntu partition is deleted and so grub cannot find files system on it (The 3 partitions listed are probably System, Data and Recovery partition for Win7). I am now trying to boot on a USB drive (where I installed a clean Ubuntu or one boot-repair liveUSB) but I have to face others issues:

I could access to the bios but everything is hidden and protected by a Administrator Password (Installed during recovery set up I think).

I also tried to use rescue mode commands, but my laptop cannot read the USB partition:

grub rescue> ls
(hd0) (hd0,msdos3) (hd0,msdos2) (hd0,msdos1) (hd1) (hd1,msdos1)
grub rescue> ls (hd1,msdos1)/
error: unknown filesystem.

I get the same error when I set prefix and root to the usb partition and try to load module with insmod command.

I don't uderstand what I did wrong because I can boot and use Ubuntu from the USB drive on another laptop (Macbook Pro)..

If anyone get the same troubles and known a solution. Thank's in advance !

  • try these commands for USB detection insmod ext2 insmod part_msdos insmod part_gpt – kenn Feb 18 '19 at 21:02
  • Your partition tables might get out of order. I met similar issue in the past askubuntu.com/questions/420778/… – kenn Feb 18 '19 at 21:07
  • Thank you for your answer. I'll try your commands soon, but I think I've already fail to load 'part_msdos' module. – Acsed. Feb 19 '19 at 19:20

Finally overcome the issue but it was tricky and long..

1. Reset BIOS

First, I decided to try the BIOS reset in order to remove the admin password that do not allow me to change boot order and give priority to USB. I completely disassemble the laptop (don't forget to get out the battery and power cable) and remove the CMOS battery for 10 minutes and put it back. After that I could enter in BIOS with admin privileges.

I think that part is not quite difficult, but a bit dangerous and could damage the laptop. It should be your last try to solve grub rescue or bios error.

2. Boot on USB flash drive

I created an USB live partition with the last Ubuntu Os from the .iso file thanks to rufus software. I choose MBR system (for BIOS or UEFI) and in NTFS format I think.

Then, I changed boot order in BIOS and I could boot on Ubuntu.

3. Fix grub bootloader

I follow the second section of that blog (without understanding exactly how lilo works) : https://mashtips.com/fix-grub-bootloader-after-deleting-ubuntu/amp/

4. Reboot on windows

After that, the computer booted directly on the recovery windows partition. As I've already used it (the reason of my issue) I press the cancel button, and I could boot on windows system partition. The final installation was quite long and the OS rebooted several times, but now everything seems ok.

Don't know if my description is very clear but it could help someone !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.