2

I follow all instructions in upgrading-ubuntu-desktop, and never see the chance to go to 18.04.2.

The command:

ubuntu-report show

  "Install": {
  "Media": "Ubuntu 18.04.1 LTS \"Bionic Beaver\" - Release amd64 (20180725)",

update manager telling me it is all up-to-date

The update manager told me about 18.10 because I had changed the option to all updates instead of only LTS. When I have it set to LTS, it shows nothing is available to update.

    31: cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=18.04
    DISTRIB_CODENAME=bionic
    DISTRIB_DESCRIPTION="Ubuntu 18.04.2 LTS"

As you can see, I do have 18.04.2. I just can't figure out in the StackExchange UI how to say my problem is solved. If someone could mark it as such, I'd appreciate it.

  • Please edit your question and post output of cat /etc/lsb-release command. – Pilot6 Feb 18 '19 at 17:19
  • 1
    Most likely you are already on 18.04.2. That command shows the initial install info. – Pilot6 Feb 18 '19 at 17:20
  • 31: cat /etc/lsb-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=18.04 DISTRIB_CODENAME=bionic DISTRIB_DESCRIPTION="Ubuntu 18.04.2 LTS" – Steven Greenberg Feb 18 '19 at 19:24
2

If you have been getting the updates, then chances are that you already have Ubuntu 18.04.2. One point to mention is that with Ubuntu 18.04.2, is the inclusion of an updated hardware stack (HWE) which is derived from Ubuntu 18.10. This means an updated kernel (Ubuntu Linux 4.18 kernel). Also included are updated versions of Xserver, Wayland, Mesa and other updated graphics drivers.The thing is, that this does not come automatically, but you can get the updated HWE by running this command:

sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04

Now:

sudo reboot

After restarting, you can see that the kernel version has been updated from 4.x.x to 4.18.x. with this command:

uname -a

By updating the HWE, you will benefit from the new hardware enablement stack, and will be able to upgrade to newer versions of the stack as they’re released.

NOTE: Those that install Ubuntu 18.04 using the new image already have this HWE.

| improve this answer | |
1

You will see the nomenclature change when the updated package base-files is installed on your system.

On my system, the update was installed on February 10th.

$apt policy base-files
base-files:
  Installed: 10.1ubuntu2.4
  Candidate: 10.1ubuntu2.4
  Version table:
 *** 10.1ubuntu2.4 500
        500 [local mirror]/us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     10.1ubuntu2.2 500
        500 [local mirror]/us.archive.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     10.1ubuntu2 500
        500 [local mirror]/us.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
| improve this answer | |
  • I don't get the connection with the numbers in your example and anything having to do with 18.04.2 – Steven Greenberg Feb 19 '19 at 2:40
  • I don't know how to explain it any other way. If that version of the package base-files is installed on your system, you've got 18.04.2 – Organic Marble Feb 19 '19 at 2:43
  • My problem is solved. I do not know what base-files means. If anywhere along the line other than finding out about in /etc/lsb-release that there was a single thing that had said 18.04.2, then I wouldn't have had to go on this chase. – Steven Greenberg Feb 19 '19 at 2:51
  • I am glad you got it solved – Organic Marble Feb 19 '19 at 3:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.