0

Since I've installed 18.04 my network has been a totally nightmare to debug. I'm with this for one day.

I really don't know what's going on. I can access some websites and others not. ping ubuntu.com does work but ping nba.com does not. In my browser when I go to ubuntu.com it does not work. apt update does not work. When I go to GUI dialog Software & Updates and Select best server no server is provided.


sudo apt update -y
Err:1 http://ppa.launchpad.net/webupd8team/atom/ubuntu bionic InRelease
  Connection failed [IP: 91.189.95.83 80]
Err:2 http://in.archive.ubuntu.com/ubuntu bionic InRelease
  Connection failed [IP: 91.189.88.162 80]
Err:3 http://in.archive.ubuntu.com/ubuntu bionic-security InRelease
  Connection failed [IP: 91.189.88.149 80]

but ping 91.189.88.83 does work

ping 91.189.95.83
PING 91.189.95.83 (91.189.95.83) 56(84) bytes of data.
64 bytes from 91.189.95.83: icmp_seq=1 ttl=56 time=20.6 ms
64 bytes from 91.189.95.83: icmp_seq=2 ttl=56 time=18.7 ms
64 bytes from 91.189.95.83: icmp_seq=3 ttl=56 time=19.6 ms
64 bytes from 91.189.95.83: icmp_seq=4 ttl=56 time=19.2 ms


cat /etc/apt/sources.list
#------------------------------------------------------------------------------#
#                            OFFICIAL UBUNTU REPOS                             #
#------------------------------------------------------------------------------#


###### Ubuntu Main Repos
deb http://in.archive.ubuntu.com/ubuntu/ bionic main restricted universe multiverse 

###### Ubuntu Update Repos
deb http://in.archive.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse 
deb http://in.archive.ubuntu.com/ubuntu/ bionic-updates main restricted universe multiverse


ifconfig

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.0  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::28c:faff:fe8a:7cba  prefixlen 64  scopeid 0x20<link>
        ether 00:8c:fa:8a:7c:ba  txqueuelen 1000  (Ethernet)
        RX packets 198488  bytes 80931214 (80.9 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 148532  bytes 71462491 (71.4 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 238660  bytes 25150962 (25.1 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 238660  bytes 25150962 (25.1 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.9  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::5e82:7f12:37f8:854f  prefixlen 64  scopeid 0x20<link>
        ether 34:de:1a:7f:93:1a  txqueuelen 1000  (Ethernet)
        RX packets 29308  bytes 10218041 (10.2 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 15815  bytes 2638177 (2.6 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

cat /etc/netplan/01-netcfg.yaml 
# This file describes the network interfaces available on your system
# For more information, see netplan(5).
network:
  version: 2
  renderer: networkd
  ethernets:
    eth0:
      dhcp4: yes
      dhcp6: yes
      addresses: [192.168.1.0/24, ]
      gateway4:  192.168.1.1
      nameservers:
              addresses: [192.168.1.1, 8.8.8.8, 8.8.4.4]

systemd-resolve --status
Global
         DNS Servers: 192.168.1.1
          DNSSEC NTA: 10.in-addr.arpa
                      16.172.in-addr.arpa
                      168.192.in-addr.arpa
                      17.172.in-addr.arpa
                      18.172.in-addr.arpa
                      19.172.in-addr.arpa
                      20.172.in-addr.arpa
                      21.172.in-addr.arpa
                      22.172.in-addr.arpa
                      23.172.in-addr.arpa
                      24.172.in-addr.arpa
                      25.172.in-addr.arpa
                      26.172.in-addr.arpa
                      27.172.in-addr.arpa
                      28.172.in-addr.arpa
                      29.172.in-addr.arpa
                      30.172.in-addr.arpa
                      31.172.in-addr.arpa
                      corp
                      d.f.ip6.arpa
                      home
                      internal
                      intranet
                      lan
                      local
                      private
                      test

Link 3 (wlan0)
      Current Scopes: DNS
       LLMNR setting: yes
MulticastDNS setting: no
      DNSSEC setting: no
    DNSSEC supported: no
         DNS Servers: 192.168.1.1

Link 2 (eth0)
      Current Scopes: DNS
       LLMNR setting: yes
MulticastDNS setting: no
      DNSSEC setting: no
    DNSSEC supported: no
         DNS Servers: 192.168.1.1
                      8.8.8.8
                      8.8.4.4
  • You can't reach Indian Ubuntu mirrors. Change to some other mirror. – Pilot6 Feb 17 at 15:01
  • @Pilot6 I can reach them, I can ping their ip. It is something else – João Pimentel Ferreira Feb 17 at 15:03
  • Does the problem go away when you connect via ethernet? – user535733 Feb 17 at 15:20
  • Mirrors may be down, try other mirrors. Indian mirrors are often down because these type of questions are common enough. – Pilot6 Feb 17 at 15:30
  • @user535733 I'm using Ethernet – João Pimentel Ferreira Feb 17 at 15:39
2

"connection failed" means the service was down, not that you have a problem with your network configuration.

Getting a response to ICMP (ping) but connection refused from apt just means that it is the web service, and not the host, which is down.

If you are consistently unable to reach some web services that you know are working from other hosts, they may be blocked by your router. There could be a captive portal that you are required to authenticate to from your web browser or other configuration required on the router side.

There is nothing in your report to suggest that the network settings you have configured are not applied correctly to the system, but we can't know if they are the correct settings for your environment.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.