8

TL;DR

I can't force my ubuntu server, after upgrading to 18.04.2 from 18.04.1, to upgrade the kernel to corresponding 4.18 version.

Historical background

Yesterday I run

sudo apt upgrade

and had a conflict on one of the minor files (I think it was /etc/issue.net). Unfortunately, during solving that conflict I accidentally turned off putty... When I logged back in I had a lock on the apt database. I restarted my server and executed

sudo dpkg --configure -a

Then sudo apt upgrade went fine. After I restarted my server I saw, in the welcome message, that my system got updated but the kernel is still in 4.15 version.

Welcome to Ubuntu 18.04.2 LTS (GNU/Linux 4.15.0-45-generic x86_64)

What I have tried so far

I tried all the solutions I could find on the Internet but none of them helped:

rychu@RychuSRV:~$ sudo apt update
Hit:1 http://ppa.launchpad.net/certbot/certbot/ubuntu bionic InRelease
Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease
Get:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Hit:4 https://download.docker.com/linux/ubuntu bionic InRelease
Get:5 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Fetched 177 kB in 1s (161 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.

rychu@RychuSRV:~$ sudo apt-get install linux-image-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-image-generic is already the newest version (4.15.0.45.47).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

rychu@RychuSRV:~$ sudo apt-get install linux-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-generic is already the newest version (4.15.0.45.47).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

rychu@RychuSRV:~$ uname -r && dpkg --get-selections linux
4.15.0-45-generic
linux-base                                      install
linux-firmware                                  install
linux-generic                                   install
linux-headers-4.15.0-45                         install
linux-headers-4.15.0-45-generic                 install
linux-headers-generic                           install
linux-image-4.15.0-23-generic                   deinstall
linux-image-4.15.0-29-generic                   deinstall
linux-image-4.15.0-30-generic                   deinstall
linux-image-4.15.0-32-generic                   deinstall
linux-image-4.15.0-33-generic                   deinstall
linux-image-4.15.0-34-generic                   deinstall
linux-image-4.15.0-36-generic                   deinstall
linux-image-4.15.0-38-generic                   deinstall
linux-image-4.15.0-39-generic                   deinstall
linux-image-4.15.0-42-generic                   deinstall
linux-image-4.15.0-43-generic                   install
linux-image-4.15.0-44-generic                   install
linux-image-4.15.0-45-generic                   install
linux-image-generic                             install
linux-modules-4.15.0-23-generic                 deinstall
linux-modules-4.15.0-29-generic                 deinstall
linux-modules-4.15.0-30-generic                 deinstall
linux-modules-4.15.0-32-generic                 deinstall
linux-modules-4.15.0-33-generic                 deinstall
linux-modules-4.15.0-34-generic                 deinstall
linux-modules-4.15.0-36-generic                 deinstall
linux-modules-4.15.0-38-generic                 deinstall
linux-modules-4.15.0-39-generic                 deinstall
linux-modules-4.15.0-42-generic                 deinstall
linux-modules-4.15.0-43-generic                 install
linux-modules-4.15.0-44-generic                 install
linux-modules-4.15.0-45-generic                 install
linux-modules-extra-4.15.0-23-generic           deinstall
linux-modules-extra-4.15.0-29-generic           deinstall
linux-modules-extra-4.15.0-30-generic           deinstall
linux-modules-extra-4.15.0-32-generic           deinstall
linux-modules-extra-4.15.0-33-generic           deinstall
linux-modules-extra-4.15.0-34-generic           deinstall
linux-modules-extra-4.15.0-36-generic           deinstall
linux-modules-extra-4.15.0-38-generic           deinstall
linux-modules-extra-4.15.0-39-generic           deinstall
linux-modules-extra-4.15.0-42-generic           deinstall
linux-modules-extra-4.15.0-43-generic           install
linux-modules-extra-4.15.0-44-generic           install
linux-modules-extra-4.15.0-45-generic           install

rychu@RychuSRV:~$ sudo update-grub
Sourcing file `/etc/default/grub'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-45-generic
Found initrd image: /boot/initrd.img-4.15.0-45-generic
Found linux image: /boot/vmlinuz-4.15.0-44-generic
Found initrd image: /boot/initrd.img-4.15.0-44-generic
Found linux image: /boot/vmlinuz-4.15.0-43-generic
Found initrd image: /boot/initrd.img-4.15.0-43-generic
Adding boot menu entry for EFI firmware configuration
done

rychu@RychuSRV:~$ sudo reboot

And...

Welcome to Ubuntu 18.04.2 LTS (GNU/Linux 4.15.0-45-generic x86_64)
rychu@RychuSRV:~$ uname -r
4.15.0-45-generic

I also tried

rychu@RychuSRV:~$ sudo do-release-upgrade
Checking for a new Ubuntu release
There is no development version of an LTS available.
To upgrade to the latest non-LTS develoment release
set Prompt=normal in /etc/update-manager/release-upgrades.

Please help.

6

You can upgrade kernel and keep it getting upgraded to future point Ubuntu releases by running

sudo apt install linux-generic-hwe-18.04

As for now it will install the 4.18 kernel.

  • Please add the info what this kernel actually is to your answer.. its essentially a backported development kernel and may contain more bugs/issues than is usually acceptable for server releases. – Robert Riedl Feb 18 at 8:19
  • It's not a "development backported kernel". It's stable Ubuntu kernel from 18.10 release. It is default in 18.04.2. You probably mix up with UKUU. – Pilot6 Feb 18 at 13:12
  • It's definitely a backported kernel see some comments from Canonical here, second paragraph: "Ubuntu's response to this is to backport more recent kernels.". I gleaned the development part from this wiki entry here, under Backwards Compatibility it says "...that the HWE kernel could track as closely as possible to the interim kernel release from which it is derived." So, while stable, it might not be rock-stable. – Robert Riedl Feb 18 at 13:43
  • Anyway when people install Ubuntu 18.04.2 they get exactly this kernel. The question was about it. How solid it rocks is an opinion issue. – Pilot6 Feb 18 at 13:45
  • True, the last kernel release for LTS recently is always hwe, to bridge over until the new LTS is available. – Robert Riedl Feb 18 at 13:47
7

I think you should be happy to stay with the 4.15 kernel series

From a conversation in an Ubuntu mail forum, an answer by Adam Conrad,

On Tue, Feb 05, 2019 at 11:53:22AM +0100, Nio Wiklund wrote: >

Will installed systems stay with this kernel series (like with the previous LTS releases) or will there be an automatic upgrade to the Cosmic kernel series and further until the next LTS kernel series:

If you install with 18.04 or 18.04.1 media and then upgrade, you will stay on the GA kernel and Xorg series. If you install with 18.04.2 or later media, you'll be on the rolling HWE kernel and X series.

... Adam

If you really want to upgrade to the new kernel series, you have to upgrade the hardware enablement stack, and it is risky. You should definitely not do it without a complete backup, so that you can easily(?) restore the system if the upgrade went wrong.

See this link: wiki.ubuntu.com/Kernel/LTSEnablementStack

  • 2
    Thank you for the explanation. v4.17 added support for some stuff that I have in my rig which will improve my server so I'll give it a try. – Rychu Feb 17 at 17:21
  • I actually installed 18.04.2 from scratch the other day and I still have 4.15-45, – Thoughtcraft Feb 20 at 0:39
  • @Thoughtcraft, The kernel version that comes with the Ubuntu 18.04.2 iso file is 4.18.0-15. Are you sure that you installed from this iso file and not from a previous iso file (Ubuntu version 18.04 or 18.04.1)? In my installed, updated & upgraded 18.04.1 system, I have the kernel that you mention, 4.15.0-45. – sudodus Feb 20 at 5:45
  • I am quite sure. I downloaded it using a torrent linked to from the Ubuntu website – Thoughtcraft Feb 20 at 6:16
  • 1
    @Thoughtcraft, Sorry, I did not see that it is an Ubuntu Server installation. It is extra important, that server systems are stable, and [I think] for that reason the default is to use a kernel with long time support (in this case the original kernel series of Ubuntu Bionic, the 4.15 kernel series, now updated to 4.15.0-45). – sudodus Feb 20 at 10:35

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.