I'm using teamviewer to help fixing my friend software. The version I use is 14.1.9025 and I install the personal use only.

After starting teamviewer for a while, TV detected that I was using commercial version and limit only 5 minute remote. I tried to search solution fix, and re-install it for several time but no result at all. I'm so desperate with teamviewer now.

enter image description here

However, when I tried using teamviewer to remote from Windows 7, it was working well, no commercial use detected.

Has anyone meet this problem, and how to fix it on Ubuntu? Please kindly help me, I really need working badly. Thanks

  • What does it say in 'More info'? – muclux Feb 17 '19 at 8:12
  • @muclux, refer to link here: teamviewer.com/en/pricing/commercial-use it said something about T&P and what is defined as commercial use. – Houy Narun Feb 17 '19 at 8:16
  • Well, on that page there is a link to a form, in case you are wrongly suspected of commercial use. – muclux Feb 17 '19 at 8:20
  • 1
    @muclux, well it's not effective as i as file a complain weeks already but no response, perhaps I don't buy 24/7 support, I saw some people filed a complain but not reply too. Thanks – Houy Narun Feb 17 '19 at 8:35

Uninstall TeamViewer.

Change system MAC address.

Install TeamViewer.

  • In case you're using a graphical session, e.g. "ubuntu": in the network's identity tab you can set the cloned MAC to random for example. Don't forget to re-activate the interface (clicking on it should suffice). You then should have a new mac address. – rosch Jul 19 '20 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.