0

I have an encrypted home folder from a 16.04 install that survived an upgrade to 18.04. Later, in 18.04, everything went wrong and now I'm having to recover my home folder from a live USB so I can copy the contents of the home folder to an external hard drive. (I'm recovering with an ubuntu-mate live USB.)

The home drive encryption was done with all the standard options on install.

Using the following command I can mount the drive (with appropriate substitutions for UUID and UNAME):

sudo mount -t ecryptfs /media/ubuntu-mate/UUID/home/.ecryptfs/UNAME/.Private /home/ubuntu-mate/Private

Here is the issue:

If I mount with the option "n" for encrypted file names, it successfully mounts but I clearly have a bunch of folders and files with encrypted names.

If I mount with the option "y" for encrypted file names, there is nothing in the mounting folder (it didn't mount?) and there are no error messages.

It does this for either option of "y" or "n" for plain text passthrough.

  • Use the ecryptfs-recover-private program (script) instead, it should handle all the details for you. – Xen2050 Feb 17 at 7:42
0

I'm not sure why, but the ecryptfs-recover-private did not work for me. It couldn't find the encrypted directory even when searching in the vicinity.

I was able to find the answer here:

How do I mount an encrypted /home directory on another Ubuntu machine?

It only works if you do exactly what it says. It looks like the ecrytpfs command defaults to the first of two entries in the File Name Encryption Key (FNEK). Per the link above, I first had to use a different command that returns TWO keys (and adds them to a keyring). Then I had to manually paste in the second key where ecrytpfs defaults to the first key. Worked perfectly after that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.