0

I have installed Ubuntu Server 18.04 onto software RAID1 using the manual disk setup as described here: https://help.ubuntu.com/lts/serverguide/advanced-installation.html.en

However, I would like to boot via UEFI, and this method does not seem to create an EFI partition. Indeed, it sets up an MS-DOS partition table instead of the GPT partition table that I would need for UEFI boot.

So I tried going the manual route following the procedure here: https://gist.github.com/umpirsky/6ee1f870e759815333c8

However this is designed to work with the ubiquity installer, and anyway I can't even get past the first step because I can't use apt-get in the installer. I tried selecting "execute a shell" at the beginning of installation, but it seems there is not apt present at that point (command not found). I also tried booting from a Gparted rescue USB (Debian based), but from there I could not install grub-efi-amd64 (no installation candidate).

Is there a good, up-to-date tutorial about my specific situation? Or how might I modify the procedures linked to above to my purposes?

1

This answer has all the information you need to get Ubuntu installed with RAID-1 and EFI / UEFI.

The critical pieces you may be missing are:

  1. Download and use the "alternate" Ubuntu server installer ISO.

  2. Ensure the installer boots through EFI rather than the standard BIOS. When the installer has booted through EFI, there will be an "EFI" partition type option when defining the disk partitions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.