4

I'd like to disable CTRL-SHIFT-U on 18.04.2.

Currently, pressing CTRL-SHIFT-U within a text prompt will make an underlined u appear on the screen and pressing keys will not append text to the prompt until Escape or Enter is pressed.

This prevents me from using the default combo in IntelliJ IDE to toggle case, and I do not wish to use something else than the default.

There are countless questions about this on Superuser and Askubuntu. I tried most of the answers, none of them has any visible effect.

Go to Language Support > Keyboard input method system > Set the value to none (some answers suggest pressing the Apply System-Wide button)

or

Add export IBUS_ENABLE_SYNC_MOVE=1 to ~/.profile and then reboot

or

Kill the ibus-daemon process

This one, the process does exist, but it respawns immediately when killed.

Throughout the answers it was implied that ibus was responsible for this behavior. There is even a GitHub issue about this. So I finally caved in and decided to try removing the ibus package by using apt-get remove ibus and apt-get purge ibus, which is suggested by one of the answers.

After rebooting, CTRL-SHIFT-U still does this thing. There is no longer any ibus-daemon process even after startup. If I go to Language Support, there is no longer ibus as a Keyboard input method system option. It is set to none, and only XIM remains as an alternative.

How come the CTRL-SHIFT-U still works even after ibus is uninstalled, and how can I disable it once and for all on Ubuntu 18.04.2?

  • FWIW it is activating unicode input, there's ctrl+shift+e for emoji input too, 😂. This page says you can use ibus-setup to change the key sequence. Are you sure ibus isn't running, you'd need to stop it as well as uninstalling (eg reboot or use sudo systemctl ...). – pbhj Feb 16 at 11:19
  • @pbhj Before uninstalling ibus and rebooting, I did try ibus-setup and only the emoji key sequence could be changed, I couldn't find where to change the unicode key sequence. Right now, ibus-setup results in command not found: ibus-setup (and the CTRL-SHIFT-U combo is still active). – Hay Feb 16 at 11:31
  • Actually, this is curious, I'm on Kubuntu 18.04.1 and I don't have ibus installed either and it all works - in Firefox - for me. Maybe it's your browser or another app that is doing the input management, it doesn't work in the native Kate for me, for example. – pbhj Feb 16 at 12:15
  • 1
    Looks like it's a Gnome thing too, hence why it works in Firefox, and Inkscape for me but not in native KDE apps. – pbhj Feb 16 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.