0

I installed Ubuntu on my Windows 10 laptop via the Windows Subsystem for Linux.

I have a NAS drive connected to my home Wi-Fi network. There's a "share" on it, accessible at \\MYCLOUDEX2ULTRA\Home that I've also mounted in Windows as my Z: drive.

When I start up the Ubuntu console, if I go to /mnt/ I can see c and d directories there (for my laptop's local hard drives), but how can I navigate to my Z Drive?

1 Answer 1

0

I tried this and it worked for me

sudo mkdir /mnt/mydesktopC

followed by

mount -t drvfs '\\mydesktop\C$' /mnt/mydesktopC

I used my C drive as a shared drive but I suppose you could do it for any share...

4
  • when I try the same mount command, I get mount: only root can use "--types" option and when I try it with sudo, I get mount: /mnt/z: special device \\MYCLOUDEX2ULTRA\Home$ does not exist.
    – osullic
    Feb 16, 2019 at 0:15
  • C$ is a default administrative share on Windows (there is one for each local drive). Is Home$ a shared folder you have defined yourself? Typically, I would not expect these shared folders to finish in $, other than the default administrative shares. If you type \\MYCLOUDEX2ULTRA within Windows Explorer, it should show you the shared folders defined
    – Eric Mamet
    Feb 16, 2019 at 14:26
  • OK sorry, I'm not a Unix or networking expert so I was just following your lead with the $. I tried again without the dollar symbol, and now get mount: /mnt/z: can't find in /etc/fstab. In /etc/fstab, there is just one line: LABEL=cloudimg-rootfs / ext4 defaults 0 0
    – osullic
    Feb 16, 2019 at 23:59
  • I am not a Unix and/or network expert either! Welcome... I would try to use "sudo" in front of mount. In my ubuntu machine, I have the same content as you in /etc/fstab
    – Eric Mamet
    Feb 17, 2019 at 16:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .