-1

After installing ubuntu 18.08 LTS along side with windows 10 , i encountered some problems using ubuntu the first is the touchpad but thanks to askubuntu i corrected the problem. Now i'm searching solutions to another problem that is with my wifi wireless connection it doesn't work and more over when entering to wifi settings i see an No Wifi Adapter Found' i already tried some stuff but unluckily not working. when typingsudo lshw -C network` i get this :

  *-network                 
       description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: enp1s0
       version: 07
       serial: 98:29:a6:67:23:2b
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp aui bnc mii fibre 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=MII
       resources: irq:16 ioport:4000(size=256) memory:b1200000-b1200fff memory:b1000000-b1003fff
  *-network UNCLAIMED
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: ioport:3000(size=256) memory:b1100000-b110ffff
  *-network
       description: Ethernet interface
       physical id: 3
       logical name: enp0s20f0u2
       serial: 22:2e:f7:46:24:ff
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.91 link=yes multicast=yes

When typing `lspci -knn | grep Net -A02:00.0 i get :

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
    Subsystem: Lenovo RTL8821CE 802.11ac PCIe Wireless Network Adapter [17aa:c024]
    Kernel modules: wl

When trying rfkill list i get :

0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Help please i want back my wireless connection

  • Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command. – Pilot6 Feb 15 '19 at 19:21
  • try: sudo modprobe 8821ce if not working then try this askubuntu.com/questions/990378/… – Leo Feb 15 '19 at 19:49
  • @Pilot6 i deed what you've requested – Said Ougouadfel Feb 15 '19 at 20:45
  • @Pilot6 any help please !!! – Said Ougouadfel Feb 22 '19 at 18:07
1

I recently got a laptop with that wifi card. Tried several guides and drivers to make it work. The easiest way (and best in my opinion, as there is a driver version around the web with a bug which after you disconnect from a network and then reconnect, it fails, you have to disable and enable wifi to be able to connect again) is to download and install the driver from this deb package: https://launchpad.net/~wenchien/+archive/ubuntu/rtl8821c/+files/oem-wifi-realtek-8821ce-lp1767920-4.15-dkms_0.8_amd64.deb Source: https://bugs.launchpad.net/ubuntu/+source/linux-oem/+bug/1740231 You will need an active internet connection to install the driver, since it will pull some packages from the Ubuntu repos.

Edit:

My apologies. You will need an active internet connection until the wifi driver is installed (ethernet cable or, if you have bluetooth, you can share from your phone or tablet connected to wifi). Instructions are for a 64bit machine. Open a Terminal and type:

sudo apt update  

This will fetch available packages in the repositories, but it will not update your system, you can do that later after fixing the wifi issue.

wget "https://launchpad.net/~wenchien/+archive/ubuntu/rtl8821c/+files/oem-wifi-realtek-8821ce-lp1767920-4.15-dkms_0.8_amd64.deb"  

This downloads the driver in form of a .deb package from a PPA.

sudo apt install ./oem-wifi-realtek-8821ce-lp1767920-4.15-dkms_0.8_amd64.deb  

Installs the downloaded driver, downloading the required package dependencies first.

exit  

Reboot and, after login, you should be able to see, connect and disconnect from available wifi networks. Hope that helps

|improve this answer|||||
  • Don't know if it works, but it would be a good idea to add the exact steps to the answer, as the OP might not know what to do with .deb packages. It might be a good idea to add the PPA properly to get updates, when available. – mikewhatever Feb 15 '19 at 22:31
  • Thanks a lot @mikewhatever i will try it and answer if it has succeeded – Said Ougouadfel Feb 16 '19 at 12:25
  • @mikewhatever thanks but it didn't work – Said Ougouadfel Feb 22 '19 at 16:47
  • and now both my bluetooth and wifi are not working – Said Ougouadfel Feb 22 '19 at 16:51
  • 1
    this does not work for me try - youtube.com/watch?v=vPfLVsyQU_A, this worked for me. I am using lenovo ideapad 130 15ikb. – Hridaynath Oct 11 '19 at 4:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.