1

I've been using Ubuntu 14.04 for years without issues, but in the last months the wifi connction seems to be broken. My computer can detect and successfully connect to wifi, but internet is off most of the time. Depending on the particular router, the connection is stable for secons/minutes/hours and then is absent for hours/days in a very unpredictable pattern (other devices can successfully connect to the same routers). Turning computer off and on and similar tricks do not seem to work, neither changing IPv4 settings does. I tried update+upgrade/reinstall options but was not successful. I tried to find a solution on the forum, but I am not an expert at all so I could not figure out what my problem is

Thank you in advance

further details here

https://paste.ubuntu.com/p/3rMxHHNKxN/

2
  • Details were collected while the wireless connection was temporarily working... hope this does not make them totally useless – lepisma Feb 15 '19 at 18:49
  • Forgot to mention that I have a hard disk partition and the wifi connection is flawless with Windows 7 – lepisma Feb 15 '19 at 21:36
0

I really need more details, but if a reinstall didn't solve it, it may be a hardware issue, which is off topic here

However, I would ensure you have all the latest drivers for your machine. There is a chance that you need proprietary drivers.

To check, either visit your device manufacturer site or use the update utility:

Go to settings->software and updates->Additional drivers

If any are available, it should find them. Unless, of course, your manufacturer does only provide Windows drivers. Also make sure to check the site of you wifi adapter manufacturer

5
  • I just checked in additional drivers – lepisma Feb 15 '19 at 19:02
  • is says "the device is not working". right now the wifi is working by the way – lepisma Feb 15 '19 at 19:03
  • If it didn't help, try the wifi adapters' manufacturer website. Else it's a hardware issue, if drivers don't help – unixandria Feb 15 '19 at 19:04
  • Sorry my fault: forgot to mention that the hard disk is partitioned (Windows and Ubuntu). On Windows side internet works just fine. Since the hardware should be shared, maybe it's more likely to be a software issue, if I understand it correcly – lepisma Feb 15 '19 at 21:34
  • In that case, it's probably a driver issue. More than likely your manufacturer doesn't official support Linux systems – unixandria Feb 15 '19 at 21:52
0

Recently my dual boot ubuntu 14.04 ASUS gaming laptop has after recent updates lost the touchpad and wifi and nothing seemed to work to get them up and running.

My solution was to select advanced options for Ubuntu in the Grub menu and choose a previous version of kernel. Specifically for my mouse issues. As of this moment for me that's version "Ubuntu, with Linux 3.13.0-163-generic" (mouse works) from the most current version "Ubuntu, with Linux 3.13.0-163-generic"(mouse fails).

I am using an rj45 connection for my network so I am wired and didn't check if it fixed wireless since I don't move this laptop around a lot, but at some point I am going to see if an earlier version will fix my wireless connectivity.

In both cases it was after an update that I loss first my wireless and then my mouse. I keep hoping these regression will get fixed in a later update but not as of yet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.