0

I'm trying to upgrade from Ubuntu 10.04 to 18.04 LTS. How?

update-manager -d --dist-upgrade reports:

| Your system is up-to-date
|
| There are no upgrades available for your system. The upgrade will
| now be canceled.

Here's what I tried:

Follow How to install software or upgrade from an old unsupported release? In /etc/apt/sources.list, replace all occurrences of ubuntu.media.mit.edu with old-releases.ubuntu.com.

In /var/lib/apt, mv lists lists.old; mkdir -p lists/partial

Apt update error - "An error occurred during the signature verification" (Chrome)

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

Even though dl.google.com and canonical don't occur in /etc/apt/sources.list, they are in some hidden configuration and cause trouble. Get info on finding them from How to install software or upgrade from an old unsupported release?; uncheck those two boxes.

apt-get update
apt-get upgrade
sudo update-manager -cd
sudo update-manager -d --dist-upgrade
3
  • 1
    @user68186 Although 10.04 is way too old release and it's been quite a long time since it reached its EOL, but I guess this question still doesn't fall under off-topic category. See this meta post: Errors while upgrading from a EOL release — should the question be closed? – Kulfy Feb 15 '19 at 19:32
  • 1
    @Quigi There is no direct way of upgrading to 18.04. You need to hop through some versions and would be full of hassles. Clean installation of 18.04 would have less hassles and will prove to be time saving. – Kulfy Feb 15 '19 at 19:34
  • @Kulfy I have retracted my close vote. – user68186 Feb 16 '19 at 14:31
1

I believe the command is

sudo do-release-upgrade

However, since the last upgradable version seems to be 14.04, you will have to use a DVD. 10.04 is not supported anymore, and therefore not upgradable. Only 14.04 on are supported; you will need a clean install

2
  • Yes, do-release-upgrade is the command. I had tried it earlier, when my sources were more messed up. By substituting old-releases.ubuntu.com I was able to connect to repositories in most cases, but there are a few not in /etc/apt/sources.list like archive.ubuntu.com which still raise 404 Not Found. – Quigi Feb 15 '19 at 21:33
  • I expected I'd need to hop through 12.04, 14.04, 16.04 to reach 18.04. But I take everyone's word that it would be full of hassles, or never work. – Quigi Feb 15 '19 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.