0

I have a configuration with an NFS mounted home directory for my user. The NFS server does not make special allowance to allow writes by the root user in the user's home directory. When conjure-up needs to change to the root user, it tries to write the file ".snap/auth.json" in the home directory, which fails.

Oops, there was a problem with your install:                  

Reason:                                                                                                            
   error: cannot add authorization: open /home/gunnar/.snap/auth.json: permission denied                       

   Review log messages at /home/gunnar/.cache/conjure-up/conjure-up.log If appropriate, please submit a bug   
   here: https://github.com/conjure-up/conjure-up/issues/new                                                   

I have not been able to find any information about this, and there does not seem to be any command-line option to use a different location for the .snap directory.

Since conjure-up refuses to run as the root user, is there any way around this short of allowing write all in the .snap directory, or creating a local user for the only purpose of executing conjure-up?

On a side note, it seems to me that the sensible thing should be to write files as the current user, instead of storing files as root (or any other user) in the user's home directory?

  • Welcome to AskUbuntu! root user? Please edit the output of more /etc/issue into your post. Thank you for helping us help you! – Elder Geek Feb 15 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.