1

I have upgrade my 32-bit a few days ago to 64-bit without to much succes.

Since that happened my apt-get installer/updater is broken and can I not do updates anymore or install software.

I am working on Ubuntu due to that we received a computer at work I needed to work on for Web Development. Due to 32-bit was I not able to get certain software installed.

Just like any other good believing person did I thought upgrading was easy just as easy as I had done so many times on Windows but actually its not.

Due to the lack of experience with Linux am I completely stuck now and do I now know how to get this solved.

Help is more than welcome.

I followed this guide its a anser in on the post with 13 likes or ups. Edited by: mxdsp and aswered by: Asterix : Is it possible to "upgrade" from a 32bit to a 64bit installation?

The error I am getting:

    The dependencies of the following packages could not be installed:

apt-utils: Depends: apt (= 1.2.29ubuntu0.1) but it is not installed
            Depends: libc6 (> = 2.4) but 2.23-0ubuntu10 is installed
            Depends: libgcc1 (> = 1: 3.0) but 1: 6.0.1-0ubuntu1 is installed
            Depends: libstdc ++ 6 (> = 5.2) but 5.4.0-6ubuntu1 ~ 16.04.11 is installed
code: Depends: libnss3 (> = 2: 3.26) but 2: 3.28.4-0ubuntu0.16.04.4 is installed
       Depends: apt but it is not installed
       Depends: libgtk-3-0 (> = 3.10.0) but 3.18.9-1ubuntu3.3 has been installed
ubuntu-minimal: Depends: apt but it is not installed
update-notifier-common: PreDepends: apt (> = 1.1 ~) but it is not installed
                         Depends: python3: any but it is a virtual package
                         Depends: update-manager-core (> = 1: 16.04.6) but 1: 16.04.15 is installed

closed as unclear what you're asking by mikewhatever, Pilot6, Eric Carvalho, Elder Geek, karel Feb 18 at 23:05

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    You mentioned 'upgrade' instead of a re-install. The change to x86 (32-bit) to x86_64 (64-bit) requires re-install. Did you re-install? or how did you 'upgrade' your system from x86 to x86_64 (ie. change architecture). – guiverc Feb 15 at 8:06
  • I actually did not re-install I have no idea at all how that works in Linux. I just did found a page and followed the steps explained there and horribly screwed up. – gaming4all plays Feb 15 at 8:10
  • 3
    Well the previous answer you apparently followed says "... took me the better part of a week. Including manually fixing 600+ broken packages in aptitude" so you shouldn't be too surprised to find yourself in this situation – steeldriver Feb 15 at 8:31
  • 3
    I would suggest you just re-install. It can be done by Backup!, download install media (the release of Ubuntu you want in x86_64), verify download (md5sum) then write to install-media. Boot it, verify it (just a safety step), then select 'install' & 'somethign else'. Something else has the option to re-install using same partitions without format, allowing you to re-install over your existing system. The installer will take note of your install apps, erase system dirs & install, then re-add the apps you had (providing they're from Ubuntu repos) & ask you to reboot. It's pretty easy. – guiverc Feb 15 at 9:22
  • 1
0

Use the command to initiate an interactive prompt of which packages you want to keep or get rid of to resolve the dependency problem:

sudo aptitude full-upgrade

This will go through a series of questions asking you which package to keep or remove. Note you don't have to select the first options given to you.

  • Thanks for the help as soon as a I run the comment I get the error: sudo: aptitude: assignment not found – gaming4all plays Feb 15 at 8:55
  • I'm going to assume you are translating and assignment not found actually means command not found in which case you'll need to apt install aptitude first. – Kristopher Ives Feb 15 at 9:00
  • Same problem. Now I get: apt: not found – gaming4all plays Feb 15 at 9:10
  • That's unfortunate, you've found yourself in a position where you have somehow removed the underlying package tools from your installation. See this answer for how to remedy that. – Kristopher Ives Feb 15 at 9:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.