8

When I go to enable the security settings on anydesk, It asks for my password and then does nothing after. I cannot set up unattended access, which is what I need to be able to work on that machine. Any ideas?

1
  • did you fix this? I tried echo command still issue is the same
    – James123
    Oct 24, 2019 at 14:28

5 Answers 5

15

This worked for me: Setting the password using the command line https://support.anydesk.com/Command_Line_Interface

echo mynewpassword | sudo anydesk --set-password
2
  • also linux mint :)
    – zzapper
    Jul 7, 2021 at 20:02
  • You can also run the following to get access to all of the admin setting, including setting your password. bash sudo anydesk --admin-settings May 4 at 0:00
5

the echo password | sudo anydesk --set-password fix does work but you need to completely restart anydesk for it to take place.

To do that, use :

ps -aux | grep anydesk 

and kill all anydesk leftover processes, then restart anydesk.

1
  • I didn't need to restart it, it worked immediately for me
    – 2080
    May 9, 2023 at 15:54
3

Based on @padje answer, I suggest you this one-line command for restarting completely anydesk :

kill $(ps -aux | grep anydesk | awk '{print $2}') | anydesk --service

Explanation :

  • ps -aux would show every active processes
  • grep anydesk would find every anydesk processes running, displayed into ps output
  • awk '{print $2}' would take the PID column (which is the 2nd)
  • kill closed every commands refered to PIDs given by combinaison of 3 previous command (ps + grep + awk). You can also add the -9 option to kill, to force them to close (notably when they are totally frozed)
  • anydesk --service would start again anydesk (correct me in comment if I do a mistake here

NB : this type of command line can be used for some software, when you want to restart them manually (and when you can't use service <software_command> restart)

2
  • Just sudo kill $(ps -aux | grep anydesk | awk '{print $2}') | anydesk --service then run anydesk again. It's enough. May 21, 2023 at 17:11
  • and you can do it automatically by editing anydesk systemd service file, sudo nano /etc/systemd/system/anydesk.service. put above line after to the ExecStart original line. like this ExecStart=/usr/bin/anydesk --service | sudo kill $(ps -aux | grep anydesk | awk '{print $2}') | /usr/bin/anydesk --service May 21, 2023 at 17:33
2

From commandline use anydesk-global-settings where you are able to do the settings using the interface.

0

Salut! If you have installed AnyDesk using Software Manager then it runs in a container called "flatpak", you can find the command in the link where you start AnyDesk and it looks like this:

/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=anydesk com.anydesk.Anydesk

To solve the problem uninstall AnyDesk using Software Manager and then download and install AnyDesk for Linux.

AnyDesk from Software Manager works perfectly for outbound connections and does not work at all for incoming connections.

If the problem is "flatpak" you can use sudo comand:

sudo /usr/bin/flatpak run --branch=stable --arch=x86_64 --command=anydesk com.anydesk.Anydesk

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .