1

I can record audio from it in Audacity just fine (it apparently uses ALSA to interact with sound card).

Not so much with any application that uses Pulseaudio, they see the device but there's always no signal. Input indicator in Settings also always looks like it's completely silent.

What could go wrong and how to fix it?

screenshot

1

It seems it gets solved by "clean reinstall" of pulseaudio with sudo apt purge pulseaudio && sudo apt install pulseaudio but it had to remove ubuntu-desktop package which I'm not sure if it's OK...

4
  • You seem not to be using "Ubuntu-Desktop" (or you would be asking another question) - but you could try to reinstall the meta package with sudo apt install ubuntu-desktop - assuming that you think you need it! Feb 14 '19 at 15:51
  • @CharlesGreen I don't know if I need it. I tried this command and it started to install terabytes of some random stuff so I pressed Ctrl+C ASAP and decided to make a decision later. But maybe there's a chance it hides something important in there too. Feb 14 '19 at 15:58
  • The desktop meta packages are interesting in an abstract sort of way - they set how the screen appears, and install a raft of routines and programs that the developers think go well with the desktop and its appearance. All of these packages and routines can be installed seperately, if desired. Feb 14 '19 at 16:03
  • alright, it seems everything was fine "without" "ubuntu-desktop" since that day... fwiw Apr 2 '19 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.