I'm having issues with Wine 1.4 in Ubuntu 11.10. To be honest, I don't know if it ever worked on this hardware (relatively new computer, had it for a few months), seeing as the Wine app I use the most hardly uses sound, but now that I tried another app, it's giving me problems. When I do an audio test in Wine Config, I get a short static sound. The selected driver appears to be winealsa.drv, do I need to change that and if so, how would I do that? I have all the input and output devices set to default, I don't think I have to change that. I also shouldn't have to restart ALSA with sudo /sbin/alsa force-reload because it seems to work fine with my other applications (unless that's all on PulseAudio?), but even when I do run that command to restart ALSA, the test sound in Wine Config is still the same short static. I thought In the one application I just tried that uses sound a lot, sound plays but insanely fast, making it practically as useless as if sound didn't work at all. Sound works perfectly from anything outside of Wine.

I think I've found the problem, though. When I go in Regedit to HKEY_CURRENT_USER/Software/Wine/, there's no Drivers key, nor Audio key. I created a Drivers key and added an Audio string with alsa as a value, didn't change anything. Edit: if I set the value to anything else, Wine Config tells me the audio driver is unavailable.

I've tried searching for a solution, went through forums (and I'll keep searching), I briefly looked at the Wine AppsDB but I don't think the problem is application-specific

Please help!

Edit: getting the debs from this place (from the Launchpad bug) tells me it has unmet dependencies, and if I try to install that dependency, Synaptic tells me it has to remove a whole lot of packages! Not willing to do that.

  • So, after your edit. I conclude you are dropping the issue? – Ringtail Mar 10 '12 at 18:17
  • No, I'm still looking for a working solution, I do a lot of troubleshooting myself so I'm trying to provide as much relevant info as possible :P – titaniumtux Mar 12 '12 at 1:47

Ok I believe to have found the solution. I did delete my .wine folder and regenerated it by launching wine config but I think what solved it was rebooting my computer. I tried running the command wineboot but that didn't suffice for some reason, maybe that command would require a parameter to work.

What I know won't work is trying to install OSS from Synaptic. Having OSS packages installed will disable sound in Ubuntu.


I have the same problem and it has been for ages. I am now running 12.04 Beta 1. This problem can be resolved if you choose the esd sound driver for Wine in the registry (if you have the sound backend installed on your machine). Whatever I did when I had 11.10 on my machine the only solution that worked was esd as sound backend for Wine. ALSA to PulseAudio for all other applications seems to work. Note that I have multichannel sound cards in my computer. Maybe plain stereo cards will work. When I change the channel configuration the sound works for about 10 minutes again.

Wine 1.4 can automatically select the proper sound backend thought.

In short, Wine, ALSA and PulseAudio together is a mess! I will wait for a proper PulseAudio sound backend.

Best regards, Andreas Eriksson

  • 1
    Hey, I hear you regarding working for maybe ~10 minutes! Can you tell me how to configure ESD as the sound backend on Wine 1.4? I agree it's a pretty big mess, and I endorse you opening an account on askubuntu just to answer my question. Is it better on Ubuntu 12.04 beta1? If ESD works as a backend and Wine audio won't crash after say 10 minutes most of the time and you tell me how to configure it, I'll accept your answer. – titaniumtux Mar 12 '12 at 1:49

I can confirm- same problem on Ubuntu 13.04, solved by running "wineboot" and then restarting (both were necessary btw).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.