7

I had the following problem when trying to do a docker-compose up:

[10:46:31] coil@coil:~/workspace/docker$ docker-compose up -d
ERROR: Couldn't connect to Docker daemon - you might need to run `docker-machine start default`.

[10:48:00] coil@coil:~/workspace/docker$ docker-machine start default
Docker machine "default" does not exist. Use "docker-machine ls" to list machines. Use "docker-machine create" to add a new one.

[10:57:07] coil@coilZ240:~/workspace/docker$ sudo docker-machine create default
Running pre-create checks...
Error with pre-create check: "VBoxManage not found. Make sure VirtualBox is installed and VBoxManage is in the path"

[11:00:17] coil@coilZ240:~/workspace/docker$ VBoxManage -v 
5.2.18_Ubuntur123745

This is weird as VBoxManage is already in the path and can be launched.

Current versions are:

  • Ubuntu: 18.04.01
  • Docker: 18.06.1-ce, build e68fc7a
  • docker-machine: 0.15.0, build b48dc28
  • VBoxManage: 5.2.18_Ubuntur123745

I installed Docker some time ago with a snap. Can you confirm that the following official installation guide is the way to go? Or is the snap version ok?

2
  • I just clicked on the Ubuntu Software. I would assume this is the "Official" Download. Feb 13, 2019 at 10:15
  • It is indeed a snap installation: /snap/bin/docker
    – COil
    Feb 13, 2019 at 10:19

3 Answers 3

5

Short answer. Don't use the snap. I reinstalled everything using the official tutorial and it works now.

1
  • I just used the official instruction guide and I'm still getting the same error message.
    – waterproof
    Mar 20, 2021 at 15:54
1

I have the same question. but my OS is Linux Mint 19.

I to do this solution solve my question

update docker-machine to version 0.16.0, build 702c267f .

reference

VBoxManage not found. Make sure VirtualBox is installed and VBoxManage is in the path

Install Docker Machine

1

Make sure your user is in the docker group. Otherwise you run docker as root and vbox as user and they can't see each other. Telltale sign that you're not in the group is that you have to sudo docker commands, e.g.:

sudo docker images

To fix, do:

sudo groupadd docker
sudo gpasswd -a <your-username> docker

Now check that user is added:

getent group docker

or:

grep /etc/group -e "docker"

Also restart docker daemon:

sudo service docker restart 

Log out and back into terminal (try restarting system if this does not work), and you should be able to run docker without sudo, e.g.:

docker images

docker machine and docker-compose should now run, too.

Fore more information, refer to this answer: https://stackoverflow.com/questions/29101043/cant-connect-to-docker-from-docker-compose

2
  • Thanks! running docker-compose with` sudo` priveleges worked Apr 24, 2021 at 8:51
  • @NuryagdyMustapayev you generally should not run docker as sudo. Adding yourself to the docker group as described in the post above is the correct approach. Running docker as sudo will potentially cause other access issues, and isn't recommended.
    – Dmitriy
    Apr 25, 2021 at 20:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .