1

I sought out advice on how to fix my keyboard, because it did not always work after being in sleep mode, so I came across this solution:

dmesg | grep i8042

and confirm you get this output

[ 1.514469] i8042: PNP: PS/2 Controller [PNP0303:KBC,PNP0f13:MOUE] at      0x60,0x64 irq 1,12
[ 1.525273] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 1.525287] serio: i8042 AUX port at 0x60,0x64 irq 12
[ 1.526035] input: AT Raw Set 2 keyboard as     /devices/platform/i8042/serio0/input/input3
[ 21.927438] input: SynPS/2 Synaptics TouchPad as    /devices/platform/i8042/serio1/input/input10
then, add the boot parameters i8042.direct and i8042.dumbkbd to    /etc/default/grub. For example, run

sudo nano /etc/default/grub

Find the line that begins GRUB_CMDLINE_LINUX_DEFAULT= and edit it to include the new parameters, so that after your edit it looks something like

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.direct i8042.dumbkbd"

Save by pressing Ctrl+O, exit by pressing Ctrl+X, and run

sudo update-grub

BUT now my keyboard is completely useless. Doesn't work at all, and the on screen keyboard works EXCEPT the letter "d" so I can't even type "sudo". Please help my reset my keyboard settings or even just reset Ubuntu all together.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.