0

I bought astrometa DVB-T2 usb tuner. On windows 10 everything working perfect.

I want to use in Ubuntu, but seems there is some problem, but don't know what:

Please help me figure out what is the problem.

W_scan :

~$ w_scan -ft -c GE
w_scan -ft -c GE 
w_scan version 20170107 (compiled for DVB API 5.10)
using settings for GEORGIA
Country identifier GE not defined. Using defaults.
scan type TERRESTRIAL, channellist 4
output format vdr-2.0
WARNING: could not guess your codepage. Falling back to 'UTF-8'
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
main:4007: FATAL: ***** NO USEABLE TERRESTRIAL CARD FOUND. *****
Please check wether dvb driver is loaded and
verify that no dvb application (i.e. vdr) is running.

$ lsmod | grep dvb

dvb_usb_rtl28xxu       40960  1
dvb_usb_v2             40960  1 dvb_usb_rtl28xxu
dvb_core              126976  2 dvb_usb_v2,rtl2832
rc_core                36864  5 lirc_dev,ir_lirc_codec,dvb_usb_v2,dvb_usb_rtl28xxu

$ lsusb

Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
**Bus 003 Device 007: ID 15f4:0131 HanfTek** << this device 
Bus 003 Device 004: ID 1c4f:0003 SiGma Micro HID controller
Bus 003 Device 003: ID 0bda:818b Realtek Semiconductor Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

sudo dmesg -t | grep dvb

[sudo] password for ggg: 
usb 3-1: Product: dvbt2
usb 3-1: Manufacturer: astrometadvbt2
usb 3-1: dvb_usb_v2: found a 'Astrometa DVB-T2' in warm state
usb 3-1: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
dvbdev: DVB: registering new adapter (Astrometa DVB-T2)
lirc lirc0: lirc_dev: driver ir-lirc-codec (dvb_usb_rtl28xxu) registered at minor = 0
usb 3-1: dvb_usb_v2: schedule remote query interval to 200 msecs
usb 3-1: dvb_usb_v2: 'Astrometa DVB-T2' successfully initialized and connected
usbcore: registered new interface driver dvb_usb_rtl28xxu
dvb_usb_v2: 'Astrometa DVB-T2:3-1' successfully deinitialized and disconnected
usb 3-1: Product: dvbt2
usb 3-1: Manufacturer: astrometadvbt2
usb 3-1: dvb_usb_v2: found a 'Astrometa DVB-T2' in warm state
dvb_usb_rtl28xxu: probe of 3-1:1.0 failed with error -110
usb 3-1: Product: dvbt2
usb 3-1: Manufacturer: astrometadvbt2
usb 3-1: dvb_usb_v2: found a 'Astrometa DVB-T2' in warm state
usb 3-1: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
dvbdev: DVB: registering new adapter (Astrometa DVB-T2)
lirc lirc0: lirc_dev: driver ir-lirc-codec (dvb_usb_rtl28xxu) registered at minor = 0
usb 3-1: dvb_usb_v2: schedule remote query interval to 200 msecs
usb 3-1: dvb_usb_v2: 'Astrometa DVB-T2' successfully initialized and connected
dvb_usb_v2: 'Astrometa DVB-T2:3-1' successfully deinitialized and disconnected
usb 3-7: Product: dvbt2
usb 3-7: Manufacturer: astrometadvbt2
usb 3-7: dvb_usb_v2: found a 'Astrometa DVB-T2' in warm state
usb 3-7: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
dvbdev: DVB: registering new adapter (Astrometa DVB-T2)
lirc lirc0: lirc_dev: driver ir-lirc-codec (dvb_usb_rtl28xxu) registered at minor = 0
usb 3-7: dvb_usb_v2: schedule remote query interval to 200 msecs
usb 3-7: dvb_usb_v2: 'Astrometa DVB-T2' successfully initialized and connected

dvb-fe-tool -a 0 -f 0

Device Realtek RTL2832 (DVB-T) (/dev/dvb/adapter0/frontend0) capabilities:
     CAN_FEC_1_2
     CAN_FEC_2_3
     CAN_FEC_3_4
     CAN_FEC_5_6
     CAN_FEC_7_8
     CAN_FEC_AUTO
     CAN_GUARD_INTERVAL_AUTO
     CAN_HIERARCHY_AUTO
     CAN_INVERSION_AUTO
     CAN_MUTE_TS
     CAN_QAM_16
     CAN_QAM_64
     CAN_QAM_AUTO
     CAN_QPSK
     CAN_RECOVER
     CAN_TRANSMISSION_MODE_AUTO
DVB API Version 5.10, Current v5 delivery system: DVBT
Supported delivery system: 
    [DVBT]

dvb-fe-tool -a 0 -f 1

WARNING  device dvb0.frontend1 not found
  • Solved: actual chip was not panasonic, it was Sony. Updated Kernet to 5.0 and now is working. – Georger Feb 18 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.