13

Possible Duplicate:
How can I replace missing configuration files after removing a package?

I have a problem in my apache2: And i exec sudo aptitude purge apache2, but in /etc/ the folder apache2 persist, after this, i move the apache2 to apacheold, and exec sudo aptitude install apache2, and this has been installed the command "apache2" but in the /etc/, the folder apache2 is not exist

0

1 Answer 1

33

First:

sudo apt-get --purge remove apache2
sudo apt-get autoremove

Then installing apache2 is as simple as:

sudo apt-get install apache2
sudo /etc/init.d/apache2 restart

To test it:

lynx "http://localhost"
5
  • Object not found! The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error. If you think this is a server error, please contact the webmaster. Error 404 localhost Apache/2.4.23 (Unix) OpenSSL/1.0.2j PHP/5.5.38 mod_perl/2.0.8-dev Perl/v5.16.3 Commented Jan 25, 2017 at 9:05
  • Welcome to phpMyAdmin Error MySQL said: Documentation Cannot connect: invalid settings. Connection for controluser as defined in your configuration failed. phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server. Retry to connect Commented Jan 25, 2017 at 9:12
  • See if you have your mysql up and running
    – LnxSlck
    Commented Jan 25, 2017 at 21:46
  • i have followed this steps it says "This site can’t be reached" for localhost although I have tried many solution. Same results obtained and neigther apache2 default configuration loaded nor the custom one Commented Mar 26, 2017 at 22:24
  • Try your local ip instead.
    – LnxSlck
    Commented Jul 7, 2017 at 21:49

Not the answer you're looking for? Browse other questions tagged .