0

I've been trying to install OpenFOAM-v1812 for windows 10 by using Ubuntu. I'm following the this guide to install the software: https://www.openfoam.com/download/install-windows-10.php After typing in the command source $HOME/.bashrc I get the following messages:

-bash: /opt/OpenFOAM/sudo: No such file or directory
chown: cannot access 'source': No such file or directory
-bash: /opt/OpenFOAM/sudo: No such file or directory
-bash: /opt/OpenFOAM/OpenFoam-v1812/etc/bashrc: No such file or directory
-bash: /opt/OpenFOAM/OpenFoam-v1812/etc/bashrc: No such file or directory

I've seen that a question like this have been asked earlier (Can't Configure Bash-Shell to Run OpenFOAM (working enviroment)), but since I'm very new with using Ubuntu and OpenFOAM I didn't get much out of the answer.

If someone has any idea of what the problem might be and how I could fix it, it would be very much appreciated!

Edit: I'm not exactly sure what steeldriver wanted me to include. When typing cat $HOME/.bashrc I got the following information:

    # ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color|*-256color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
        # We have color support; assume it's compliant with Ecma-48
        # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
        # a case would tend to support setf rather than setaf.)
        color_prompt=yes
    else
        color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# colored GCC warnings and errors
#export GCC_COLORS='error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01'

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi
source /opt/OpenFOAM/sudo tar -xvzf  OpenFOAM-v1812-windows10.tgz -C /opt/
sudo chown -R sigurdov /opt/OpenFOAM/OpenFOAM-v1812/etc/bashrc source /home/sigurdov/.bashrc
source /opt/OpenFOAM/sudo tar -xvzf  OpenFOAM-v1812-windows10.tgz -C /opt/
sudo chown -R sigurdov /opt/OpenFOAM/OpenFOAM-v1812/etc/bashrc
source /opt/OpenFOAM/OpenFOAM-v1812/etc/bashrc
source /opt/OpenFOAM/OpenFOAM-v1812/etc/bashrc
source /opt/OpenFOAM/OpenFOAM-v1812/etc/bashrc
source /opt/OpenFOAM/OpenFoam-v1812/etc/bashrc
source /opt/OpenFOAM/OpenFoam-v1812/etc/bashrc
source /opt/OpenFOAM/OpenFOAM-v1812/etc/bashrc

Please note me if this wasn't what you meant.

  • 1
    It looks like you misunderstood the instructions, causing your $HOME/.bashrc file to become messed up. Please edit your question to include its contents (from cat $HOME/.bashrc or equivalent). – steeldriver Feb 12 at 14:41
  • I've editet the post to include the message I got when typing ´cat $HOME/.bashrc´. I hope it'll help understanding the problem! – Siganno Feb 12 at 15:04
  • You need to remove ALL the lines after the final fi and start over, following the instructions more carefully this time (in particular noting when you are supposed to run commands in the bash terminal versus adding them as lines to the $HOME/.bashrc file) – steeldriver Feb 12 at 15:16
  • I think that did the trick! Thank you for your advice! – Siganno Feb 14 at 7:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.