So I got laptop running on Ubuntu 18.04.1 (Deepin Desktop Enviroment). Laptop has 2 GPUs:

  • Amd Radeon R7 M360
  • AMD Radeon R5 (APU)

My question is how do I switch to R7?

Running command lspci reveals that both GPUs are detected: `

01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445] [1002:6900] (rev ff) (prog-if ff)
    !!! Unknown header type 7f
    Kernel driver in use: amdgpu
    Kernel modules: amdgpu

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R4/R5 Graphics] [1002:9851] (rev 45) (prog-if 00 [VGA controller])
    Subsystem: Hewlett-Packard Company Mullins [Radeon R4/R5 Graphics] [103c:80b8]
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 38
    Region 0: Memory at b0000000 (64-bit, prefetchable) [size=256M]
    Region 2: Memory at d0800000 (64-bit, prefetchable) [size=8M]
    Region 4: I/O ports at f000 [size=256]
    Region 5: Memory at feb00000 (32-bit, non-prefetchable) [size=256K]
    Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: radeon
    Kernel modules: radeon, amdgpu


When playing minecraft, it detects as AMD Mullins (R5 GPU)

  • Are you using Ubuntu or Deepin? There was no 2018.January (18.01) release of Ubuntu.
    – guiverc
    Feb 12, 2019 at 9:24
  • sorry, im using 18.4.1 and im using just deepin desktop enviroment (insted of gnome)
    – Milan
    Feb 12, 2019 at 11:49

1 Answer 1


I'm guessing your laptop supports switchable graphics via DRI_PRIME. If so, my solution to this problem is:

  1. Install lutris (https://lutris.net)
  2. Open lutris and navigate to it's Preferences
  3. Go to "System options"
  4. Enable "Show advanced settings"
  5. Scroll until you see the option "Use discrete graphics" and enable it.

Optionally you can also create a desktop shortcut through lutris.

Now when you run the minecraft launcher and run any minecraft instance through it you should see your discrete adapter in F3.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.