2

The function keys to control the screen brightness - Fn-F11 & Fn-F12 - are not working.

Xubuntu 18.10.

Dell Inspiron 17 7000 (7786) laptop

I have tried updating the boot parameters in /etc/default/grub

Currently running: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset acpi_osi=! "acpi_osi=Windows 2015""

I also tried these options: "acpi_osi=" "acpi_osi=Linux"

Some more checks:

ls -l /sys/class/backlight

...shows nothing.

xrandr --verbose | grep Bright

...shows nothing.

sudo showkey

...shows 224 for Fn-F11 (brightness down) and 225 for Fn-F12 (brightness up).

The other function keys - volume, keyboard backlight, wireless on/off, etc... are working OK.

0

This solution worked for me:

Taken from:

Brightness fn key shortcut doesn't work on ASUS laptop

and

13.10 Can't Adjust Dell Laptop Backlight

...but not the same.

1. Create file: /usr/share/X11/xorg.conf.d/20-intel.conf

Open terminal and type these commands:

sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

Add the following lines to this file:

Section "Device"
    Identifier  "card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    BusID       "PCI:0:2:0"
EndSection

Save the file and close nano.

2. Update Grub settings

In a terminal and type these commands:

sudo nano /etc/default/grub

find the line starting with:

GRUB_CMDLINE_LINUX_DEFAULT

and add the option "acpi_backlight=vendor" (without the quotes).

E.g.: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Save the file and exit nano.

In a in terminal:

sudo update-grub

Restart your laptop and it will work probably...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.