4

After an upgrade from 18.04 to 18.10, my ubuntu does not boot and just losing the signal after the grub.

I cat login with "nomodeset" but then the resolution is lower and can't be changed.

Here are my graphic card details. It was working perfectly before the last updates using the Ubuntu 18.04 default driver.

> lspci -vnn | grep VGA -A 12
> 
> 01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc.
> [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] [1002:68f9]
> (prog-if 00 [VGA controller])     Subsystem: ASUSTeK Computer Inc. Cedar
> [Radeon HD 5000/6000/7350/8350 Series] [1043:035e]    Flags: bus master,
> fast devsel, latency 0, IRQ 10    Memory at e0000000 (64-bit,
> prefetchable) [size=256M]     Memory at f7dc0000 (64-bit,
> non-prefetchable) [size=128K]     I/O ports at c000 [size=256]    Expansion
> ROM at 000c0000 [disabled] [size=128K]    Capabilities: <access denied>
>   Kernel modules: radeon

The used graphic driver is:

llvmpipe (LLVM 7.0, 128 bits)

The mesa current driver version is:

OpenGL version string: 3.1 Mesa 18.2.2

I also tried the ppa:oibaf/graphics-drivers and also the Mesa 18.3. . It is still not booting without the nomodeset and the resolution stays unchangeable.

The kernel version is : 4.18.0.15.16

I also installed the 4.20.7 kernel but same exit on boot problem.

I am not a gamer so I do not need special 3D capabilities.

UPDATE:

I've created a 18.10 installation USB and tried booting from it to try Ubuntu from the USB. The USB starts and shows 2 icons at the bottom but then loses the signal to the screen before even showing the firs menu.

So, I created a 18.04 installation USB (18.04.2) but the same lost signal problem happened. I can't even install the 18.04 again.

It looks like there was a driver or kernel change that created this problem already in the 18.04 distribution.

UPDATE 2

I can only login with nomodeset. Here is the output from

sudo lshw -c video

> *-display UNCLAIMED       
>        description: VGA compatible controller
>        product: Cedar [Radeon HD 5000/6000/7350/8350 Series]
>        vendor: Advanced Micro Devices, Inc. [AMD/ATI]
>        physical id: 0
>        bus info: pci@0000:01:00.0
>        version: 00
>        width: 64 bits
>        clock: 33MHz
>        capabilities: pm pciexpress msi vga_controller bus_master cap_list
>        configuration: latency=0
>        resources: memory:e0000000-efffffff memory:f7dc0000-f7ddffff ioport:c000(size=256) memory:c0000-dffff

Any ideas what to try?

Thanks a lot

2
  • 1
    The upgrade was a bad idea. I suggest to re-install 18.04 LTS.
    – Pilot6
    Feb 16 '19 at 12:58
  • I have the same problem after updating 18.04 itself. Feb 29 '20 at 20:11
0

Start Ubuntu with "nomodeset" than go to Software Update > Settings > Additional Drivers and look for entries here. Ubuntu should auto-detect drivers that will suit your graphic card.

2
  • 1
    I do log in using nomodeset because it's the only option, but there are no additional drivers detected. Usually, the correct drivers are the mesa drivers but there is probably a problem with their update or with the kernel update of Ubuntu.
    – Drorasta
    Feb 13 '19 at 12:28
  • AMD proprietary drivers for these cards don't support new releases.
    – Pilot6
    Feb 16 '19 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.