0

I'm using a dual boot Ubuntu 18.04 / Windows10 in my SSD and I have my old HDD with Windows 10 installed in my laptop too.

At the first time I was able to get into my HDD from Ubuntu and delete/create files, copy/paste and so on, but now it is mounted as read-only. Doing some search I found this command:

sudo mount -o remount,uid=1000,gid=1000,rw /dev/sda4

But if it mounts it as media. If I try to create a folder in that disk shows me an error saying no such file or directory.

What am I doing wrong?

0

This is probably caused by Windows 10, the way it shutdown (which in reality is not a proper shutdown).

Quick way to solve it: in Win10, when you do Start -> Shutdown, keep SHIFT key pressed as you click on Shutdown. After that, when you boot into Ubuntu, you should have write access to all your disks and partitions.

If you find yourself in the situation of forgetting to press SHIFT while shutting down, you may want to read this answer to disable the fast startup.

0

Open the terminal (CTRL+ALT+T) and copy and paste sudo nautilus . If it does not work please restart your machine into windows and then again into ubuntu. The problem you are experiencing is usually caused by improper shutdown of windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.