0

I have recently installed Ubuntu 18.10 on my laptop. I tried to install the LTS version first but the wi fi wouldn't work. Now after I updated my Linux it works but very slow(max 400 kb/s speed when on Windows 10 I have 3-4 mb/s).Sometimes the wi fi on Linux stops randomly and i got very bad signal even near my router. Any advice?

Laptop: Kiano Elegance 14.2 OS: Ubuntu 18.10 SSD 120 GB Dual Boot with windows 10 pro 4GB Ram It doesn't have ethernet only Wifi, ironically I used an usb wi fi adapter to connect firstly to wifi to update linux beacuse otherwise the wifi wouldn't work

sudo lshw -C Network

  *-network                
       description: Wireless interface
       physical id: 1
       bus info: usb@1:7
       logical name: wlxac35ee58886a
       serial: ac:35:ee:58:88:6a
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8xxxu driverversion=4.18.0-15-generic firmware=N/A ip=192.168.43.191 link=yes multicast=yes wireless=IEEE 802.11
:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 1122:3341  
Bus 001 Device 003: ID 0bda:b720 Realtek Semiconductor Corp.
Bus 001 Device 002: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
0

What you could try:

  1. unload the driver and reload it with different antenna settings: https://unix.stackexchange.com/a/412761 or https://bbs.archlinux.org/viewtopic.php?id=237619 posting 23

    • sudo modpobe -rv rtl8xxxu && sudo modprobe -v rtl8xxxu ant_sel=1or
    • sudo modpobe -rv rtl8xxxu && sudo modprobe -v rtl8xxxu ant_sel=2or
    • sudo modpobe -rv rtl8xxxu && sudo modprobe -v rtl8xxxu ant_sel=0or
  2. unload the driver and load a different one: https://www.linuxquestions.org/questions/linux-networking-3/drivers-installed-wifi-card-still-uses-the-generic-rtl8xxxu-4175622767/#post5813975

    • sudo modprobe -rv rtl8xxxu && sudo modprobe -v rtl8723au
  3. one last option could be to install and compile a driver from here https://github.com/lwfinger/rtl8723bu

  • it says that rtl8xxu module couldn't be found – BENTA MARIUS Feb 12 at 15:20
  • it's strange that if I use my mobile to hotspot the wifi works normally but on other wifi networks it sometimes works for a short period of time or sometimes it doesn't – BENTA MARIUS Feb 12 at 15:22
  • i did write wrong, you have triple x (rtl8xxxu) but i wrote with double x (rlt8xxu). – AlexOnLinux Feb 12 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.