0

I am running Ubuntu 18.04 on my ASUS TUF FX504 laptop with kernel 4.20.6.

srajan@srajans-asus:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.1 LTS
Release:    18.04
Codename:   bionic
srajan@srajans-asus:~$ uname -a
Linux srajans-asus 4.20.6-042006-generic #201901310331 SMP Thu Jan 31 08:33:33 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

The Elantech touchpad didn't work untill kernel 4.18. With 4.19 and 4.20, it started working but used to freeze for 3-4 minutes randomly.To solve this, I tried

sudo modprobe -r psmouse
sudo modprobe  psmouse

After which my touchpad completely stopped working.I tried rebooting with older kernels but nothing changed.

The touchpad works perfectly until login screen, and then freezes at botton right cornet. Upon pressing Ctrl+Alt+F7, I get i2c_hid_get_input incomplete report repeatedly on every powercycle.

Here is a log of my xinput

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ELAN1200:00 04F3:3090 Touchpad            id=14   [slave  pointer  (2)]
⎜   ↳ USB OPTICAL MOUSE                         id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Asus Wireless Radio Control               id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=11   [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=15   [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam: USB2.0 HD           id=13   [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=16   [slave  keyboard (3)]
    ↳ Video Bus                                 id=9    [slave  keyboard (3)]

I am unable to restore my touchpad. Please help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.