0

In my AWS EC2 instance, I hosted my website few days back. The website has apache, php, mysql and elasticsearch installed. Few days back I updated my site with SSL certification. I configured a security group include inbound to:

HTTP, SSH and HTTPS

My website is rendering properly and I am able to ssh into my EC2 instance. However, when i tried to update some python libraries, I could not do so - I get a connection timed out error after a minute. So is apt update command. When I tried ping www.google.com nothing happens.

I tried adding custom ICMP rule as given in this post in my security group. However, it did not help.

I tried appending ipv6 conf in /etc/systyl.conf as given in this post. This too did not help.

I am completely new to this and I am DIY person. I am not sure how to proceed further and don't want to meddle with. Can someone help?

  • Security Groups add https and select anywhere – GHOST Feb 15 at 7:00
  • 1
    @GHOST Thank you...I did that...but didn't work. I had to change parameters on my VPU to allow all traffic and it started working. Not sure whether it is correct or not.... – Apricot Feb 15 at 7:04
  • when you type your ip address its that show default apache2 home page? – GHOST Feb 15 at 7:05
  • 1
    @GHOST yes it does...since i have configured an index page as the default page for my url, that page gets loaded. – Apricot Feb 15 at 7:07
  • make sure http and https are select from any where and then restart apache2 and check – GHOST Feb 15 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.