1

i am quite new to linux

i am looking for the wget 1.20 package for bionic beaver

according to wiki wget 1.20 was released on November 2018 , however i cannot seem to find the .deb file for bionic , i only found the version for disco but i got libpcre2-8-0 dependency issue (requires version 10.32 & that version is not updated for bionic yet)

the main reason for upgrading to wget 1.20 is for the new "--retry-on-host-error" option

so from where can i get the package?

New contributor
Nice3456 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 1
    It won't be 'updated for bionic'. Ubuntu 18.04 shipped with wget 1.19, and it will have 1.19 (suitably patched for security updates) for it's entire life. wget 1.20 is in Ubuntu 19.04, which will be released in April 2019. 19.04 packages are NOT designed to run on an 18.04 system - you can try, but doing so is not supported and it might break your system quite horribly. – user535733 Feb 11 at 14:58
  • You could try to compile wget from source, but this requires quite some libraries. – koni_raid Feb 11 at 15:39
2

Please mention it as wget 1.20 and not wget 1.2 since they would refer to very different package versions.

As someone else has commented, you're probably out of luck with it comes to getting the newer package on your old distro. As you've mentioned, using the file from the new distro won't work well since it was compiled with newer libraries.

However, you could consider getting the tarball for Wget and compiling it locally, yourself. Just do:

$ wget https://ftp.gnu.org/gnu/wget/wget-latest.tar.gz
$ mkdir wget-latest && tar xzf wget-latest.tar.gz --strip-components 1 -C wget-latest
$ cd wget-latest
$ ./configure
$ make

You can then use the wget executable from src/wget. You could also install it as a local user if you like.

  • 1
    You might need some extra libs: sudo apt-get install build-essential pkg-config libssl-dev libpsl-dev libghc-gnutls-dev – koni_raid Feb 11 at 15:48
  • or apt-get build-dep wget would be enough. – N0rbert Feb 11 at 20:22
  • thank you , after installing the extra libs wget was successfully compiled – Nice3456 Feb 12 at 7:02
  • You don't need both libssl-dev and gnutls-dev. Either one is enough. – darnir Feb 12 at 8:25

Your Answer

Nice3456 is a new contributor. Be nice, and check out our Code of Conduct.

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.