0

I ran the code below

sudo apt-get update
sudo apt-get install libx11-dev
sudo apt-get install libimlib2-dev

and paste "make" in my ubuntu on GCP but requested to install make package so I use the command

sudo apt-get install build-essential

and after that I use make command in ssocr dir and an error message below:

make: imlib2-config: Command not found   
make: imlib2-config: Command not found   
cc -D_FORTIFY_SOURCE=2 -Wall -W -Wextra -pedantic -Werror -pedantic-errors -fstack-protector-all -O3 -c -o ssocr.o ssocr.c   
ssocr.c:21:53: fatal error: X11/Xlib.h: No such file or directory   
compilation terminated.   
<builtin>: recipe for target 'ssocr.o' failed   
make: *** [ssocr.o] Error 1   

So please comment how to fix it.

  • 1
    Did the first sudo apt-get install command complete without errors? What is your Ubuntu version? – steeldriver Feb 11 at 13:03
  • It looked so and only informed me some memory space will be added and asked me [Y/n]. But one thing I did noted was once Y input it showed "Abort". My ubuntu was 16.04.3. Should I run 'sudo apt-get install' again? @N0bert – Michael C.H. Wang Feb 11 at 20:20
  • I run sudo apt-get install libimlib2-dev again and it works now. – Michael C.H. Wang Feb 11 at 20:32

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.