It claims to have "Applications" selected on the right side, but doesn't find anything other than Files & Folders. I have no way of launching programs except via terminal. And no way of finding the list of installed programs.

I tried removing the zeitgeist index as per this similar question, but it didn't do anything.

This is what I see when I open it:

screenshot of my unity

More info: I've been having this issue for months on 16.04, and hoped it would be fixed by upgrading to 18.04. It was, of course, since that switched me to GNOME Shell 3, but I switched back to Unity so I could get all of my custom compiz settings, and the issue came back.

More more info: none of the toggles on the right seem to do anything, except the Files & Folders one, which, if unselected, means that nothing gets shown as results.

  • 1
    Check if the app lens is installed, sudo apt install unity-lens-applications , if it installs then log out/in to ck. – doug Feb 18 at 2:19
  • @doug "unity-lens-applications is already the newest version" – MalcolmOcean Feb 18 at 23:06
  • Have you tried creating another user account and logging in under that account to see if you get applications in search results? If so, then it might be isolated to something specific to your user folder, such as a single corrupt .desktop file. – Steve Feb 19 at 15:16
  • sudo apt install --reinstall unity-lens-applications just to be safe – Robert Riedl Feb 22 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.