2

I just upgraded to 18.04 and I'm loving the new look but I'm horrified to discover that all of my customizations added by CompizConfig Settings Manager aren't working!

I've tried uninstalling & reinstalling compizconfig-settings-manager, and moving the ~/.compiz folder to try to get it to reset, but that's not helping. It's clearly not that it's lost my settings so much as that it's not connected to whatever it's supposed to affect.

e.g. if I reset the settings and then try turning on Firepaint just as a test, nothing happens when I press the Firepaint shortcut..

I'm about to try restarting (now that I've uninstalled & reinstalled ccsm) to see if that helps. UPDATE: Restarting didn't help.

1
  • Gnome Shell replaced Unity in 18.04 as the default desktop and Gnome Shell doesn't use Compiz. See my answer below to install Unity to get Compiz up and running.
    – mchid
    Feb 10 '19 at 22:40
2

Before you begin, please enable the Universe repository.


Unfortunately, 18.04 uses Gnome Shell instead of Unity and so Compiz doesn't work.

Fortunately, you can install the old Unity based Ubuntu desktop by running the following commands:

sudo apt update
sudo apt install ubuntu-unity-desktop unity-session unity-greeter

This will also install a lightdm session manager which will give you the more familiar login experience. When prompted, select lightdm from the list of session managers to replace the now default gdm session manager.

If you do not see that option, please run the following command to switch to lightdm:

sudo dpkg-reconfigure lightdm

and then select lightdm when prompted.

For a full list of additional packages like unity scopes and lenses, run the following command:

apt-cache search unity | grep -P '^unity'

Now, reboot and make sure to select the Unity session by clicking on the icon to the left of the login box when you log back in.

After you log back in, the CompizConfig Session Manager will work just like it used to.

12
  • "Unable to locate package session" As far as I know, I've enabled the Universe repository... Feb 10 '19 at 22:44
  • Yeah, main, universe, restricted, & multiverse are all enabled. Feb 10 '19 at 22:44
  • 1
    It looks like maybe you meant unity-session (with a hyphen). At any rate, both unity-session and unity-greeter are "already the newest version". Feb 10 '19 at 22:49
  • Hm, based on linuxconfig.org/… I've tried installing ubuntu-unity-desktop but nothing happened after I did. Feb 10 '19 at 22:52
  • Just ran sudo dpkg-reconfigure gdm3 and it looks like I've now been able to select lightdm, and when I rebooted I selected Unity instead of the other options (like that link suggested). Feb 10 '19 at 23:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.