I have been running Ubuntu 18.04 for a couple of weeks. I upgraded from 16.04 and all went smoothly.

I am not sure what I changed, but this morning I noticed that the "Settings" Icon that launches gnome-control-center is missing from "Show Applications" and the applications menu as well. When I searched from "Show Applications" for gnome-control-center or just settings, nothing showed up.

So, I figured I must have accidentally removed it and figured a reinstall of the package would resolve the issue. I have searched and found several postings where this worked. I tried:

sudo apt install gnome-control-center

And then rebooted - which reinstalled the gnome-control-center and I could then launch it from the command line. However, there was still no Settings Icon in any of the menus.

I also tried many other suggestions including:

sudo apt-get install --reinstall gnome-control-center
sudo apt-get install ubuntu-desktop
sudo apt install ubuntu-desktop --reinstall
sudo apt-get install unity-control-center

However, none of these has been successful in restoring the icon into "Show Applications" or any applications menu.

Anyone have any suggestions on something I haven't tried? Would be much appreciated. Or, is there a way to just manually recreate the icon?

Output of locate gnome-control-center.desktop:


I am running Ubuntu 18.04 desktop on kernel 4.15.0-45-generic.

  • @Klufy Thanks. Locate shows /usr/share/applications/gnome-control-center.desktop /home/dccrens/.local/share/applications/gnome-control-center.desktop and /home/dccrens/.gnome/apps/gnome-control-center.desktop
    – Dave
    Feb 10, 2019 at 17:16
  • @Klufy cat shows: $ cat /usr/share/applications/gnome-control-center.desktop [Desktop Entry] Name=Settings
    – Dave
    Feb 10, 2019 at 17:21
  • cat /usr/share/applications/gnome-control-center.desktop [Desktop Entry] Name=Settings # Translators: Do NOT translate or transliterate this text (this is an icon file name)! Icon=gnome-control-center Exec=gnome-control-center Terminal=false Type=Application StartupNotify=true Categories=GNOME;GTK;Settings; OnlyShowIn=GNOME;Unity; X-GNOME-Bugzilla-Bugzilla=GNOME X-GNOME-Bugzilla-Product=gnome-control-center X-GNOME-Bugzilla-Component=shell X-GNOME-Bugzilla-Version=3.28.2
    – Dave
    Feb 10, 2019 at 17:22
  • # Translators: Search terms to find this application. Do NOT translate or localize the semicolons! The list MUST also end with a semicolon! Keywords=Preferences;Settings; X-Ubuntu-Gettext-Domain=gnome-control-center-2.0
    – Dave
    Feb 10, 2019 at 17:23
  • @Klufy - Your question put me on the answer! Copying the /usr/share/applications/gnome-control-center.desktop to the two other locations in my home directory fixed it. Thanks
    – Dave
    Feb 10, 2019 at 17:33

4 Answers 4


In my case I just ran

sudo apt-get install --reinstall gnome-control-center

rebooted the system, and it was restored. It is now working fine again.


Call me dumb, but I was "missing" settings in gnome-control-center because it opened in a submenu (Devices). Reinstalling didn't work. Googling didn't work.

All I had to do was click the back button in the top left...

  • Same here, thanks for pointing it out.
    – progonkpa
    Apr 30, 2021 at 19:08
  • This is correct.
    – Wastrel
    Jun 18, 2023 at 2:56

Shortcuts in "Show Application" menu is shown by the Desktop Entry of the corresponding app. According to output of locate gnome-control-center.desktop, there are two extra gnome-control-center.desktop located in /home/dccrens/.gnome/apps/ and /home/dccrens/.local/share/applications/ which are creating the issue. Delete that files using Nautilus or rm /home/dccrens/.gnome/apps/gnome-control-center.desktop /home/dccrens/.local/share/applications/gnome-control-center.desktop.


I was suddenly missing Settings in my Ubuntu18.04.3LTS; not in the Launcher nor in the Applications anymore. did re-install "gnome control center" from the Ubuntu software center and now Settings is working fine again, and the icon is back in Launcher and Applications.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .