0

I need to vertify my domain to get a https certificate, my problem is that the page says that I have to put a file in a folder named .well-known. The Problem is now that I can't access this folder with my browser, there is written "Forbidden" when I connect to my page?

Does someone know how to fix this?

1

Use a text editor. First find out what files are in your .blah_blah file w/ ls -l /home/user/.blah_blah/files.filetype.

Also: I found this info. in a book I was reading, "Mastering Ubuntu Server, (LaCroix 2018)."

  1. The web developer creates the website and related files

  2. These files are uploaded to the Ubuntu Server, typically in a subdirectory of /var/www or another directory the administrator has chosen

  3. The server administrator creates a configuration file for the site, and copies it into the /etc/apache2/sites-available directory

  4. The administrator enables the site and reloads Apache

This cmd should show you the files in that dir.

Seth

P.S. If that does not work, try sudo. If you just need to find your . files or your "invisible files," try ls -l /home/user/. Also, try to add the correct permissions to your file that you need to add so you can read/write to it. This may help.

| improve this answer | |
1

You probably have an Apache directive for files matching ..* which is preventing access via the web (files like .htaccess or folders like .svn or .git). You need to edit your virtualhost configuration to allow access to the folder .well_known for the host you're validating.

<Directory "/var/www/your_domain/.well_known"> Options Indexes FollowSymLinks MultiViews AllowOverride None Order allow,deny Allow from all </Directory>

If you're using letsencrypt you can let certbot handle everything or use a dns plugin with certbot to add and remove a TXT record.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.