0

Yesterday,I was configuring Java Path for installing Netbeans Apache,then I went to sleep.Today,when I'm trying to login with correct username and password ,the screen gets stuck to display login again. I tried all the answers:

Ubuntu gets stuck in a login loop

My Ubuntu gets stuck in a login loop due to the incompatibility with nvidia driver [duplicate]

The result of sudo cat .xsession-errors is :

Xsession: X session started for root at Sat Feb  9 16:49:52 CET 2019
dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/alaeddine/.Xauthority
localuser:root being added to access control list
dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
dbus-update-activation-environment: setting SUDO_GID=1000
dbus-update-activation-environment: setting MAIL=/var/mail/root
dbus-update-activation-environment: setting USER=root
dbus-update-activation-environment: setting HOME=/home/alaeddine
dbus-update-activation-environment: setting QT4_IM_MODULE=xim
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-1YeMPItkMC,guid=70b8a7d6bd2d984b274e80eb5c5ef6a2
dbus-update-activation-environment: setting SUDO_UID=1000
dbus-update-activation-environment: setting IM_CONFIG_PHASE=1
dbus-update-activation-environment: setting LOGNAME=root
dbus-update-activation-environment: setting GTK_IM_MODULE=ibus
dbus-update-activation-environment: setting TERM=linux
dbus-update-activation-environment: setting USERNAME=root
dbus-update-activation-environment: setting WINDOWPATH=2
dbus-update-activation-environment: setting PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting LANG=en_US.UTF-8
dbus-update-activation-environment: setting XAUTHORITY=/home/alaeddine/.Xauthority
dbus-update-activation-environment: setting XMODIFIERS=@im=ibus
dbus-update-activation-environment: setting SUDO_COMMAND=/usr/bin/startx
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting SUDO_USER=alaeddine
dbus-update-activation-environment: setting GPG_AGENT_INFO=/home/alaeddine/.gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting QT_IM_MODULE=ibus
dbus-update-activation-environment: setting JAVA_HOME=/usr/lib/jvm/jdk-11.0.2
dbus-update-activation-environment: setting PWD=/home/alaeddine
dbus-update-activation-environment: setting XDG_DATA_DIRS=/usr/share/gnome:/usr/local/share/:/usr/share/
dbus-update-activation-environment: setting CLUTTER_IM_MODULE=xim

steeldriver said in this thread that the PATH is housed ,but I did not get what I do because it does not provide a full response.

  • I think your situation is different (the only reference to PATH in your .xsession-errors is PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin which looks OK to me). Did you need to use sudo to cat the file? is so, it would point to an issues with the file or parent directory ownership/permissions. – steeldriver Feb 9 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.