0

Per other threads I've verified that .Xauthority and .ICEauthoriy belong to my user, that I have free space on disk, and that /tmp is permissioned correctly

ls -lA
-rw-------  1 eights eights      51 Feb  8 12:31  .Xauthority
drwxrwxrwt  13 root root    602112 Feb  8 12:38 tmp

I looked at .xsession-errors it's just a bunch of setting lines

dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/eights/.Xauthority
...

I can login via SSH and TTY2, I've tried purging all nvidia packages and rebooting (login fails) then re-installing nvidia-384 and rebooting (login still fails).

I looked at Xorg.1.log and didn't see anything interesting (no EE, no WW)

https://pastebin.com/rwapVqqT

sudo startx fails but without useful information

X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-138-generic x86_64 Ubuntu
Current Operating System: Linux eights 4.15.0-45-generic #48-Ubuntu SMP Tue Jan 29 16:28:13 UTC 2019 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-45-generic root=UUID=93d06854-e049-4ccd-b9de-bdb2fe89b6ae ro acpi_enforce_resources=lax quiet splash vt.handoff=1
Build Date: 25 October 2018  04:11:27PM
xorg-server 2:1.19.6-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.34.0
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Fri Feb  8 12:44:48 2019
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

I've tried installing lightdm (and toggling desktop environment between ubuntu and ubuntu with wayland) both don't work. With gdm3 unity works (but I want what I had before). I tried purging and installing ubuntu-desktop but that doesn't fix it either :(

  • 1
    This isn't a forum! Please do not post a solution in the question itself (or add "solved"). Please remove the edit and post it as an answer that you can later accept and receive points for it. – user880592 Feb 9 '19 at 2:38
0

It turned out one of my gnome-shell extensions was broken. I had tried gnome-shell-extensions-tool -d <NAME> which claims it disabled the extension but I had to move the folder out of the directory to fix it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.